./devel/kf5/threadweaver [KDE helper for multithreaded programming]
[+] Add this package to your ports tracker

[ CVSweb ] [ Homepage ] [ RSS feed ]

Version: 5.43.0, Package name: threadweaver-5.43.0
Maintained by: KDE porting team
Master sites:
Description
ThreadWeaver is a helper for multithreaded programming. It uses a job-based
interface to queue tasks and execute them in an efficient way.

You simply divide the workload into jobs, state the dependencies between the
jobs and ThreadWeaver will work out the most efficient way of dividing the work
between threads within a set of resource limits.


Filesize: 1376.191 KB
Version History (View Complete History)
  • (2018-02-27) Updated to version: threadweaver-5.43.0
  • (2018-02-13) Updated to version: threadweaver-5.42.0
  • (2018-01-10) Updated to version: threadweaver-5.41.0
  • (2017-10-26) Updated to version: threadweaver-5.38.0
  • (2017-06-08) Updated to version: threadweaver-5.34.0
  • (2016-12-25) Updated to version: threadweaver-5.29.0
  • (2016-05-27) Package added to openports.se, version threadweaver-5.21.0 (created)
[show/hide] View available PLISTS (Can be a lot of data)

CVS Commit History:

   2018-02-26 13:33:07 by Rafael Sadowski | Files touched by this commit (94)
Log message:
Update KDE Frameworks to 5.43.0
Changelog:
https://www.kde.org/announcements/kde-frameworks-5.43.0.php
   2018-02-12 12:35:37 by Rafael Sadowski | Files touched by this commit (102)
Log message:
Update KDE Frameworks to 5.42.0
Changelog:
https://www.kde.org/announcements/kde-frameworks-5.42.0.php
bulk and ok landry@ Thanks a lot!
   2018-01-09 14:10:40 by Rafael Sadowski | Files touched by this commit (155)
Log message:
Update KDE Frameworks to 5.41.0
Update kdelibs4support to 5.39.0 and not to 5.41.0 because otherwise the
openssl stuff will do too much work.
(Make kssl compile against OpenSSL 1.1.0 (bug 370223)).
Tested in an bulk by landry@ Thanks!
ok landry@
   2018-01-09 14:10:40 by Rafael Sadowski | Files touched by this commit (155)
Log message:
Update KDE Frameworks to 5.41.0
Update kdelibs4support to 5.39.0 and not to 5.41.0 because otherwise the
openssl stuff will do too much work.
(Make kssl compile against OpenSSL 1.1.0 (bug 370223)).
Tested in an bulk by landry@ Thanks!
ok landry@
   2017-07-27 03:34:38 by Stuart Henderson | Files touched by this commit (86)
Log message:
add COMPILER_LIBCXX to WANTLIB and bump
   2017-06-07 11:03:39 by Rafael Sadowski | Files touched by this commit (165)
Log message:
Update KDE Frameworks to 5.34.0
A few tweaks from zhuk@. Thanks!
ok jca@
   2017-06-07 11:03:39 by Rafael Sadowski | Files touched by this commit (165)
Log message:
Update KDE Frameworks to 5.34.0
A few tweaks from zhuk@. Thanks!
ok jca@
   2016-12-25 07:54:49 by Vadim Zhukov | Files touched by this commit (170)
Log message:
Update KDE Frameworks to 5.29.0 and sync with Qt5.
A few tweaks are coming, but things should build at least for now.
Most work done from Rafael Sadowski, thanks!
   2016-12-25 07:54:49 by Vadim Zhukov | Files touched by this commit (170)
Log message:
Update KDE Frameworks to 5.29.0 and sync with Qt5.
A few tweaks are coming, but things should build at least for now.
Most work done from Rafael Sadowski, thanks!