./devel/libpeas [gobject-based plugins engine]
[+] Add this package to your ports tracker

[ CVSweb ] [ Homepage ] [ RSS feed ]

Version: 1.20.0, Package name: libpeas-1.20.0
Maintained by: Jasper Lievisse Adriaanse, Antoine Jacoutot
Master sites:
Description
libpeas is a gobject-based plugins engine, and is targetted at giving
every application the chance to assume its own extensibility. It is
currently used by several GNOME applications like gedit and Totem.

It takes its roots in the old gedit plugins engine, and provides an
extensive set of features mirroring the desiderata of most of the
applications providing an extension framework.


Filesize: 544.797 KB
Version History (View Complete History)
  • (2016-10-29) Updated to version: libpeas-1.20.0
  • (2016-04-20) Updated to version: libpeas-1.18.0
  • (2015-10-03) Updated to version: libpeas-1.16.0
  • (2015-04-03) Updated to version: libpeas-1.14.0
  • (2014-10-05) Updated to version: libpeas-1.12.1
  • (2014-08-10) Updated to version: libpeas-1.10.1
  • (2014-03-31) Updated to version: libpeas-1.10.0
  • (2013-06-18) Updated to version: libpeas-1.8.1
  • (2013-03-29) Updated to version: libpeas-1.8.0
  • (2012-11-25) Updated to version: libpeas-1.6.2
[show/hide] View available PLISTS (Can be a lot of data)

CVS Commit History:

   2017-01-03 11:54:49 by Alexandr Shadchin | Files touched by this commit (37)
Log message:
Add a MODPY_PYOEXTENSION variable.
Beginning with Python 3.5 .pyo files are no longer used and
have been replaced by a more flexible scheme that includes
the optimization level explicitly in .pyc name (See PEP-488).
   2017-01-03 11:54:49 by Alexandr Shadchin | Files touched by this commit (37)
Log message:
Add a MODPY_PYOEXTENSION variable.
Beginning with Python 3.5 .pyo files are no longer used and
have been replaced by a more flexible scheme that includes
the optimization level explicitly in .pyc name (See PEP-488).
   2016-10-29 02:24:42 by Jasper Lievisse Adriaanse | Files touched by this commit (2)
Log message:
update to libpeas-1.20.0
   2016-10-29 02:24:42 by Jasper Lievisse Adriaanse | Files touched by this commit (2)
Log message:
update to libpeas-1.20.0
   2016-04-20 00:20:11 by Jasper Lievisse Adriaanse | Files touched by this commit (3)
Log message:
update to libpeas-1.18.0
   2016-04-20 00:20:11 by Jasper Lievisse Adriaanse | Files touched by this commit (3)
Log message:
update to libpeas-1.18.0
   2016-04-20 00:20:11 by Jasper Lievisse Adriaanse | Files touched by this commit (3)
Log message:
update to libpeas-1.18.0
   2015-10-03 08:48:09 by Jasper Lievisse Adriaanse | Files touched by this commit (4)
Log message:
update to libpeas-1.16.0
   2015-10-03 08:48:09 by Jasper Lievisse Adriaanse | Files touched by this commit (4)
Log message:
update to libpeas-1.16.0
   2015-10-03 08:48:09 by Jasper Lievisse Adriaanse | Files touched by this commit (4)
Log message:
update to libpeas-1.16.0
   2015-10-03 08:48:09 by Jasper Lievisse Adriaanse | Files touched by this commit (4)
Log message:
update to libpeas-1.16.0
   2015-07-17 15:33:07 by Jasper Lievisse Adriaanse | Files touched by this commit (1)
Log message:
drop now unneeded patch and just use sed
   2015-05-14 12:20:34 by Jasper Lievisse Adriaanse | Files touched by this commit (1)
Log message:
committed upstream
   2015-05-12 06:39:10 by Jasper Lievisse Adriaanse | Files touched by this commit (1)
Log message:
fix regress tests on OpenBSD; with upstream
   2015-04-15 03:40:54 by Antoine Jacoutot | Files touched by this commit (68)
Log message:
Bump after libepoxy moved from ports to xenocara.
   2015-04-04 03:21:09 by Antoine Jacoutot | Files touched by this commit (301)
Log message:
Bump after the recent changes in packaging dbus and dconf.
   2015-04-02 13:22:41 by Jasper Lievisse Adriaanse | Files touched by this commit (8)
Log message:
update to libpeas-1.14.0
   2015-04-02 13:22:41 by Jasper Lievisse Adriaanse | Files touched by this commit (8)
Log message:
update to libpeas-1.14.0
   2015-04-02 13:22:41 by Jasper Lievisse Adriaanse | Files touched by this commit (8)
Log message:
update to libpeas-1.14.0
   2015-04-02 13:22:41 by Jasper Lievisse Adriaanse | Files touched by this commit (8)
Log message:
update to libpeas-1.14.0
   2015-04-02 13:22:41 by Jasper Lievisse Adriaanse | Files touched by this commit (8)
Log message:
update to libpeas-1.14.0
   2015-04-02 13:22:41 by Jasper Lievisse Adriaanse | Files touched by this commit (8)
Log message:
update to libpeas-1.14.0
   2015-04-02 13:22:41 by Jasper Lievisse Adriaanse | Files touched by this commit (8)
Log message:
update to libpeas-1.14.0
   2015-04-02 13:22:41 by Jasper Lievisse Adriaanse | Files touched by this commit (8)
Log message:
update to libpeas-1.14.0
   2015-03-27 02:46:21 by Antoine Jacoutot | Files touched by this commit (13)
Log message:
x11/gtk+2,-guic -> x11/gtk+3,-guic && bump
   2014-11-12 03:47:12 by Jasper Lievisse Adriaanse | Files touched by this commit (5)
Log message:
rework local patches with proposed patch from upstream
   2014-11-12 03:47:12 by Jasper Lievisse Adriaanse | Files touched by this commit (5)
Log message:
rework local patches with proposed patch from upstream
   2014-11-12 03:47:12 by Jasper Lievisse Adriaanse | Files touched by this commit (5)
Log message:
rework local patches with proposed patch from upstream
   2014-11-12 03:47:12 by Jasper Lievisse Adriaanse | Files touched by this commit (5)
Log message:
rework local patches with proposed patch from upstream
   2014-11-12 03:47:12 by Jasper Lievisse Adriaanse | Files touched by this commit (5)
Log message:
rework local patches with proposed patch from upstream
   2011-06-10 03:38:18 by Antoine Jacoutot | Files touched by this commit (2)
Log message:
Don't install the glade catalog file, there are still issues with glade
support in libpeas.
   2011-06-10 03:38:18 by Antoine Jacoutot | Files touched by this commit (2)
Log message:
Don't install the glade catalog file, there are still issues with glade
support in libpeas.
   2011-06-08 11:40:09 by Jasper Lievisse Adriaanse | Files touched by this commit (27)
Log message:
bump after default python version switch
   2011-06-05 15:01:13 by Jasper Lievisse Adriaanse | Files touched by this commit (1)
Log message:
use ${MODPY_WANTLIB} instead of the actual python library, this would break
when the default python version changes. found out the hard way by landry@
   2011-05-13 06:39:11 by Antoine Jacoutot | Files touched by this commit (2)
Log message:
Enable seed support.
   2011-05-13 06:39:11 by Antoine Jacoutot | Files touched by this commit (2)
Log message:
Enable seed support.
   2011-04-28 01:35:19 by Antoine Jacoutot | Files touched by this commit (2)
Log message:
Regen PLIST after the itlocaledir fix in the gnome MODULE.
   2011-04-28 01:35:19 by Antoine Jacoutot | Files touched by this commit (2)
Log message:
Regen PLIST after the itlocaledir fix in the gnome MODULE.