./geo/postgis [geographic objects support for PostgreSQL]
[+] Add this package to your ports tracker

[ CVSweb ] [ Homepage ] [ RSS feed ]

Version: 2.3.3, Package name: postgis-2.3.3
Maintained by: Landry Breuil
Master sites:
Description
PostGIS adds support for geographic objects to the PostgreSQL
object-relational database. In effect, PostGIS "spatially enables"
the PostgreSQL server, allowing it to be used as a backend spatial
database for geographic information systems (GIS), much like ESRI's
SDE or Oracle's Spatial extension. PostGIS follows the OpenGIS
"Simple Features Specification for SQL" and has been certified as
compliant with the "Types and Functions" profile.


Filesize: 11076.203 KB
Version History (View Complete History)
  • (2017-07-04) Updated to version: postgis-2.3.3
  • (2017-02-07) Updated to version: postgis-2.3.2
  • (2016-10-31) Updated to version: postgis-2.3.0
  • (2016-04-27) Updated to version: postgis-2.2.2
  • (2015-10-30) Updated to version: postgis-2.2.0
  • (2015-07-21) Updated to version: postgis-2.1.8
  • (2015-04-03) Updated to version: postgis-2.1.7
  • (2015-03-25) Updated to version: postgis-2.1.6
  • (2014-12-20) Updated to version: postgis-2.1.5
  • (2014-09-03) Updated to version: postgis-2.1.3
[show/hide] View available PLISTS (Can be a lot of data)

CVS Commit History:

   2017-07-26 16:45:35 by Stuart Henderson | Files touched by this commit (937)
Log message:
bump LIBCXX/LIBECXX/COMPILER_LIBCXX ports.
   2017-07-16 13:19:06 by Marc Espie | Files touched by this commit (880)
Log message:
use COMPILER_LIBCXX where applicable
   2017-07-03 11:02:15 by Landry Breuil | Files touched by this commit (3)
Log message:
Update to postgis 2.3.3.
See http://postgis.net/2017/07/01/postgis-2.3.3/
   2017-07-03 11:02:15 by Landry Breuil | Files touched by this commit (3)
Log message:
Update to postgis 2.3.3.
See http://postgis.net/2017/07/01/postgis-2.3.3/
   2017-07-03 11:02:15 by Landry Breuil | Files touched by this commit (3)
Log message:
Update to postgis 2.3.3.
See http://postgis.net/2017/07/01/postgis-2.3.3/
   2017-04-10 05:46:23 by Stuart Henderson | Files touched by this commit (276)
Log message:
use LIBCXX
   2017-02-07 01:15:30 by Landry Breuil | Files touched by this commit (3)
Log message:
Update to postgis 2.3.2.
See http://postgis.net/2017/01/31/postgis-2.3.2/
   2017-02-07 01:15:30 by Landry Breuil | Files touched by this commit (3)
Log message:
Update to postgis 2.3.2.
See http://postgis.net/2017/01/31/postgis-2.3.2/
   2017-02-07 01:15:30 by Landry Breuil | Files touched by this commit (3)
Log message:
Update to postgis 2.3.2.
See http://postgis.net/2017/01/31/postgis-2.3.2/
   2016-11-04 05:35:21 by Stuart Henderson | Files touched by this commit (100)
Log message:
sync WANTLIB (and in one case, add gettext to LIB_DEPENDS) in dependent ports
now that internationalised domain name support has been removed from net/curl
   2016-10-31 10:08:08 by Landry Breuil | Files touched by this commit (4)
Log message:
Major update to postgis 2.3.0.
See http://postgis.net/2016/09/26/postgis-2.3.0/
   2016-10-31 10:08:08 by Landry Breuil | Files touched by this commit (4)
Log message:
Major update to postgis 2.3.0.
See http://postgis.net/2016/09/26/postgis-2.3.0/
   2016-10-31 10:08:08 by Landry Breuil | Files touched by this commit (4)
Log message:
Major update to postgis 2.3.0.
See http://postgis.net/2016/09/26/postgis-2.3.0/
   2016-10-31 10:08:08 by Landry Breuil | Files touched by this commit (4)
Log message:
Major update to postgis 2.3.0.
See http://postgis.net/2016/09/26/postgis-2.3.0/
   2016-09-23 03:16:58 by Stuart Henderson | Files touched by this commit (124)
Log message:
Cope with moving sqlite3 back to ports.
   2016-07-09 02:46:25 by Stuart Henderson | Files touched by this commit (15)
Log message:
sync WANTLIB
   2016-04-26 14:19:01 by Landry Breuil | Files touched by this commit (5)
Log message:
Update to postgis 2.2.2.
See http://postgis.net/2016/01/06/postgis-2.2.1/
and http://postgis.net/2016/03/22/postgis-2.2.2/
   2016-04-26 14:19:01 by Landry Breuil | Files touched by this commit (5)
Log message:
Update to postgis 2.2.2.
See http://postgis.net/2016/01/06/postgis-2.2.1/
and http://postgis.net/2016/03/22/postgis-2.2.2/
   2016-04-26 14:19:01 by Landry Breuil | Files touched by this commit (5)
Log message:
Update to postgis 2.2.2.
See http://postgis.net/2016/01/06/postgis-2.2.1/
and http://postgis.net/2016/03/22/postgis-2.2.2/
   2016-04-26 14:19:01 by Landry Breuil | Files touched by this commit (5)
Log message:
Update to postgis 2.2.2.
See http://postgis.net/2016/01/06/postgis-2.2.1/
and http://postgis.net/2016/03/22/postgis-2.2.2/
   2016-04-26 14:19:01 by Landry Breuil | Files touched by this commit (5)
Log message:
Update to postgis 2.2.2.
See http://postgis.net/2016/01/06/postgis-2.2.1/
and http://postgis.net/2016/03/22/postgis-2.2.2/
   2016-03-18 17:12:22 by Christian Weisgerber | Files touched by this commit (183)
Log message:
remove SHARED_ONLY from ports that only use modules that neither set nor
read this variable
   2015-10-30 06:47:41 by Stuart Henderson | Files touched by this commit (43)
Log message:
sync WANTLIB (curl+nghttp2)
   2015-10-30 06:19:41 by Landry Breuil | Files touched by this commit (4)
Log message:
Add upstream patch removing BOM markers from source files. Everyone
loves UTF8 but gcc.
   2015-10-30 06:19:41 by Landry Breuil | Files touched by this commit (4)
Log message:
Add upstream patch removing BOM markers from source files. Everyone
loves UTF8 but gcc.
   2015-10-30 06:19:41 by Landry Breuil | Files touched by this commit (4)
Log message:
Add upstream patch removing BOM markers from source files. Everyone
loves UTF8 but gcc.
   2015-10-30 06:19:41 by Landry Breuil | Files touched by this commit (4)
Log message:
Add upstream patch removing BOM markers from source files. Everyone
loves UTF8 but gcc.
   2015-10-30 06:09:51 by Jasper Lievisse Adriaanse | Files touched by this commit (1)
Log message:
unbreak
   2015-10-30 06:08:09 by Landry Breuil | Files touched by this commit (1)
Log message:
Remove README explaining how to preload libpthread in postgresql, it
seems it's not needed anymore.
   2015-10-30 06:07:12 by Landry Breuil | Files touched by this commit (3)
Log message:
Update to postgis 2.2.0.
See http://postgis.net/2015/10/07/postgis-2.2.0 for details.
Now versions liblwgeom so USE_LIBTOOL is needed.
Remove LD_PRELOAD=libpthread.so for tests since it isnt needed anymore
(spotted by abieber@)
rtpostgis still has issues during tests but it doesnt seem a regression,
and i'll look into this.
   2015-10-30 06:07:12 by Landry Breuil | Files touched by this commit (3)
Log message:
Update to postgis 2.2.0.
See http://postgis.net/2015/10/07/postgis-2.2.0 for details.
Now versions liblwgeom so USE_LIBTOOL is needed.
Remove LD_PRELOAD=libpthread.so for tests since it isnt needed anymore
(spotted by abieber@)
rtpostgis still has issues during tests but it doesnt seem a regression,
and i'll look into this.
   2015-10-30 06:07:12 by Landry Breuil | Files touched by this commit (3)
Log message:
Update to postgis 2.2.0.
See http://postgis.net/2015/10/07/postgis-2.2.0 for details.
Now versions liblwgeom so USE_LIBTOOL is needed.
Remove LD_PRELOAD=libpthread.so for tests since it isnt needed anymore
(spotted by abieber@)
rtpostgis still has issues during tests but it doesnt seem a regression,
and i'll look into this.
   2015-07-21 02:02:38 by Landry Breuil | Files touched by this commit (3)
Log message:
Bugfix update to postgis 2.1.8
   2015-07-21 02:02:38 by Landry Breuil | Files touched by this commit (3)
Log message:
Bugfix update to postgis 2.1.8
   2015-07-21 02:02:38 by Landry Breuil | Files touched by this commit (3)
Log message:
Bugfix update to postgis 2.1.8
   2015-04-03 06:49:41 by Landry Breuil | Files touched by this commit (3)
Log message:
Update to postgis 2.1.7 and switch to databases/postgresql MODULE for
test target handling, thanks to zhuk@!
   2015-04-03 06:49:41 by Landry Breuil | Files touched by this commit (3)
Log message:
Update to postgis 2.1.7 and switch to databases/postgresql MODULE for
test target handling, thanks to zhuk@!
   2015-04-03 06:49:41 by Landry Breuil | Files touched by this commit (3)
Log message:
Update to postgis 2.1.7 and switch to databases/postgresql MODULE for
test target handling, thanks to zhuk@!
   2015-03-24 15:45:01 by Landry Breuil | Files touched by this commit (3)
Log message:
Bugfix update to postgis 2.1.6.
See http://postgis.net/2015/03/20/postgis-2.1.6 for details.
Not converted to postgresql MODULE for test targets.. because that can
come in a second time :)
   2015-03-24 15:45:01 by Landry Breuil | Files touched by this commit (3)
Log message:
Bugfix update to postgis 2.1.6.
See http://postgis.net/2015/03/20/postgis-2.1.6 for details.
Not converted to postgresql MODULE for test targets.. because that can
come in a second time :)
   2015-03-24 15:45:01 by Landry Breuil | Files touched by this commit (3)
Log message:
Bugfix update to postgis 2.1.6.
See http://postgis.net/2015/03/20/postgis-2.1.6 for details.
Not converted to postgresql MODULE for test targets.. because that can
come in a second time :)
   2014-12-19 13:34:59 by Landry Breuil | Files touched by this commit (4)
Log message:
Bugfix update to postgis 2.1.5.
See http://svn.osgeo.org/postgis/tags/2.1.5/NEWS for changes, regress
tests still all pass on amd64.
   2014-12-19 13:34:59 by Landry Breuil | Files touched by this commit (4)
Log message:
Bugfix update to postgis 2.1.5.
See http://svn.osgeo.org/postgis/tags/2.1.5/NEWS for changes, regress
tests still all pass on amd64.
   2014-12-19 13:34:59 by Landry Breuil | Files touched by this commit (4)
Log message:
Bugfix update to postgis 2.1.5.
See http://svn.osgeo.org/postgis/tags/2.1.5/NEWS for changes, regress
tests still all pass on amd64.
   2014-12-19 13:34:59 by Landry Breuil | Files touched by this commit (4)
Log message:
Bugfix update to postgis 2.1.5.
See http://svn.osgeo.org/postgis/tags/2.1.5/NEWS for changes, regress
tests still all pass on amd64.
   2010-11-21 02:33:56 by Landry Breuil | Files touched by this commit (1)
Log message:
Fix after proj update: add -pthread to LDFLAGS.
   2010-11-17 01:05:18 by Marc Espie | Files touched by this commit (317)
Log message:
new depends
   2010-11-08 07:32:56 by Eric Faurot | Files touched by this commit (1)
Log message:
bump after postgresql update.
suggested by and ok landry@
   2010-11-04 07:45:54 by Eric Faurot | Files touched by this commit (5)
Log message:
- update postgis to 1.5.2
- install documentation properly
NOTE: An upgrade of all postgis DBs is required. A "hard upgrade" is
advised. A "soft upgrade" might be possible by keeping a copy of
/usr/local/lib/postgresql/postgis-1.4.so. In all cases, read the
documentation.
ok landry@ jasper@
   2010-11-04 07:45:54 by Eric Faurot | Files touched by this commit (5)
Log message:
- update postgis to 1.5.2
- install documentation properly
NOTE: An upgrade of all postgis DBs is required. A "hard upgrade" is
advised. A "soft upgrade" might be possible by keeping a copy of
/usr/local/lib/postgresql/postgis-1.4.so. In all cases, read the
documentation.
ok landry@ jasper@
   2010-11-04 07:45:54 by Eric Faurot | Files touched by this commit (5)
Log message:
- update postgis to 1.5.2
- install documentation properly
NOTE: An upgrade of all postgis DBs is required. A "hard upgrade" is
advised. A "soft upgrade" might be possible by keeping a copy of
/usr/local/lib/postgresql/postgis-1.4.so. In all cases, read the
documentation.
ok landry@ jasper@
   2010-11-04 07:45:54 by Eric Faurot | Files touched by this commit (5)
Log message:
- update postgis to 1.5.2
- install documentation properly
NOTE: An upgrade of all postgis DBs is required. A "hard upgrade" is
advised. A "soft upgrade" might be possible by keeping a copy of
/usr/local/lib/postgresql/postgis-1.4.so. In all cases, read the
documentation.
ok landry@ jasper@
   2010-11-04 07:45:54 by Eric Faurot | Files touched by this commit (5)
Log message:
- update postgis to 1.5.2
- install documentation properly
NOTE: An upgrade of all postgis DBs is required. A "hard upgrade" is
advised. A "soft upgrade" might be possible by keeping a copy of
/usr/local/lib/postgresql/postgis-1.4.so. In all cases, read the
documentation.
ok landry@ jasper@
   2010-10-18 15:50:39 by Stuart Henderson | Files touched by this commit (48)
Log message:
fix tabs
   2010-10-18 12:13:15 by Marc Espie | Files touched by this commit (150)
Log message:
USE_GROFF=Yes
   2009-08-06 04:30:20 by Eric Faurot | Files touched by this commit (8)
Log message:
update to 1.4.0
For upgrading a postgis-enabled db, refer to
/usr/local/share/doc/postgresql/postgis/README.postgis
Try using new_postgis_restore.pl instead of postgis_restore.pl
if it doesn't work.
feedback and ok kili@ landry@
   2009-08-06 04:30:20 by Eric Faurot | Files touched by this commit (8)
Log message:
update to 1.4.0
For upgrading a postgis-enabled db, refer to
/usr/local/share/doc/postgresql/postgis/README.postgis
Try using new_postgis_restore.pl instead of postgis_restore.pl
if it doesn't work.
feedback and ok kili@ landry@
   2009-08-06 04:30:20 by Eric Faurot | Files touched by this commit (8)
Log message:
update to 1.4.0
For upgrading a postgis-enabled db, refer to
/usr/local/share/doc/postgresql/postgis/README.postgis
Try using new_postgis_restore.pl instead of postgis_restore.pl
if it doesn't work.
feedback and ok kili@ landry@
   2009-08-06 04:30:20 by Eric Faurot | Files touched by this commit (8)
Log message:
update to 1.4.0
For upgrading a postgis-enabled db, refer to
/usr/local/share/doc/postgresql/postgis/README.postgis
Try using new_postgis_restore.pl instead of postgis_restore.pl
if it doesn't work.
feedback and ok kili@ landry@
   2009-08-06 04:30:20 by Eric Faurot | Files touched by this commit (8)
Log message:
update to 1.4.0
For upgrading a postgis-enabled db, refer to
/usr/local/share/doc/postgresql/postgis/README.postgis
Try using new_postgis_restore.pl instead of postgis_restore.pl
if it doesn't work.
feedback and ok kili@ landry@
   2009-08-06 04:30:20 by Eric Faurot | Files touched by this commit (8)
Log message:
update to 1.4.0
For upgrading a postgis-enabled db, refer to
/usr/local/share/doc/postgresql/postgis/README.postgis
Try using new_postgis_restore.pl instead of postgis_restore.pl
if it doesn't work.
feedback and ok kili@ landry@
   2009-08-06 04:30:20 by Eric Faurot | Files touched by this commit (8)
Log message:
update to 1.4.0
For upgrading a postgis-enabled db, refer to
/usr/local/share/doc/postgresql/postgis/README.postgis
Try using new_postgis_restore.pl instead of postgis_restore.pl
if it doesn't work.
feedback and ok kili@ landry@
   2009-08-06 04:30:20 by Eric Faurot | Files touched by this commit (8)
Log message:
update to 1.4.0
For upgrading a postgis-enabled db, refer to
/usr/local/share/doc/postgresql/postgis/README.postgis
Try using new_postgis_restore.pl instead of postgis_restore.pl
if it doesn't work.
feedback and ok kili@ landry@
   2009-02-18 05:04:14 by Jasper Lievisse Adriaanse | Files touched by this commit (3)
Log message:
- update postgis to 1.3.5
from benoit lecocq, via eric@ (MAINTAINER
   2009-02-18 05:04:14 by Jasper Lievisse Adriaanse | Files touched by this commit (3)
Log message:
- update postgis to 1.3.5
from benoit lecocq, via eric@ (MAINTAINER
   2009-02-18 05:04:14 by Jasper Lievisse Adriaanse | Files touched by this commit (3)
Log message:
- update postgis to 1.3.5
from benoit lecocq, via eric@ (MAINTAINER