BROKEN: undefined reference to '_ZN6icu_5613UnicodeStringC1EOS0_'


./graphics/mapnik [toolkit for developing mapping applications]
[+] Add this package to your ports tracker

[ CVSweb ] [ Homepage ] [ RSS feed ]

Version: 3.0.10, Package name: mapnik-3.0.10
Maintained by: Landry Breuil
Master sites:
Description
Mapnik is an OpenSource C++/Python toolkit for developing GIS
(Geographic Information Systems) applications. At the core is a C++
shared library providing algorithms/patterns for spatial data access
and visualization.
Essentially a collection of geographic objects (map, layer,
datasource, feature, geometry), the library doesn't rely on
"windowing systems" and can be deployed in any server environment.
It is intended to play fair in a multi-threaded environment and is
aimed primarily, but not exclusively, at web-based development.


Filesize: 84188.504 KB
Version History (View Complete History)
  • (2016-09-05) Updated to version: mapnik-3.0.10
  • (2015-09-19) Updated to version: mapnik-3.0.5
  • (2013-07-06) Updated to version: mapnik-2.2.0
  • (2012-05-03) Updated to version: mapnik-2.0.1
  • (2010-10-25) Package added to openports.se, version mapnik-0.7.1 (created)
[show/hide] View available PLISTS (Can be a lot of data)

CVS Commit History:

   2017-08-24 03:45:24 by Stuart Henderson | Files touched by this commit (42)
Log message:
bump; textproc/icu4c now uses multi-packages for -wwwdata
   2017-07-26 16:45:35 by Stuart Henderson | Files touched by this commit (937)
Log message:
bump LIBCXX/LIBECXX/COMPILER_LIBCXX ports.
   2017-07-16 13:19:06 by Marc Espie | Files touched by this commit (880)
Log message:
use COMPILER_LIBCXX where applicable
   2017-05-31 02:08:18 by Marc Espie | Files touched by this commit (173)
Log message:
switch everything to new COMPILER idiom, even stuff that won't build with clang
yet, but at least that part is done.
   2016-09-23 03:16:58 by Stuart Henderson | Files touched by this commit (124)
Log message:
Cope with moving sqlite3 back to ports.
   2016-09-22 08:27:23 by Christian Weisgerber | Files touched by this commit (1)
Log message:
Mark as BROKEN again.  The problem refuses to go away on its own.
   2016-09-04 10:46:57 by Landry Breuil | Files touched by this commit (5)
Log message:
Update to 3.0.10, still BROKEN because of missing symbol for
_ZN6icu_5713UnicodeStringC1EPKciEOS0_. Maybe switching icu to build with
a decent compiler would help, but that's not planned for now...
   2016-09-04 10:46:57 by Landry Breuil | Files touched by this commit (5)
Log message:
Update to 3.0.10, still BROKEN because of missing symbol for
_ZN6icu_5713UnicodeStringC1EPKciEOS0_. Maybe switching icu to build with
a decent compiler would help, but that's not planned for now...
   2016-09-04 10:46:57 by Landry Breuil | Files touched by this commit (5)
Log message:
Update to 3.0.10, still BROKEN because of missing symbol for
_ZN6icu_5713UnicodeStringC1EPKciEOS0_. Maybe switching icu to build with
a decent compiler would help, but that's not planned for now...
   2016-09-04 10:46:57 by Landry Breuil | Files touched by this commit (5)
Log message:
Update to 3.0.10, still BROKEN because of missing symbol for
_ZN6icu_5713UnicodeStringC1EPKciEOS0_. Maybe switching icu to build with
a decent compiler would help, but that's not planned for now...
   2016-09-04 10:46:57 by Landry Breuil | Files touched by this commit (5)
Log message:
Update to 3.0.10, still BROKEN because of missing symbol for
_ZN6icu_5713UnicodeStringC1EPKciEOS0_. Maybe switching icu to build with
a decent compiler would help, but that's not planned for now...
   2015-12-01 00:05:42 by Antoine Jacoutot | Files touched by this commit (1)
Log message:
BROKEN.
   2015-11-24 01:23:08 by Landry Breuil | Files touched by this commit (1)
Log message:
Mark as ONLY_FOR_ARCHS=amd64, gcc OOM's on i386/powerpc/sparc64 anyway,
and there's no point in wasting bazillions of cpu cycles on this c++11
monster there.
Makes sense to sthen@
   2015-09-22 03:52:43 by Stuart Henderson | Files touched by this commit (1)
Log message:
can't build mapnik on i386, not enough memory
   2015-09-18 14:07:09 by Landry Breuil | Files touched by this commit (24)
Log message:
Update to mapnik 3.0.5.
Switch to use gcc 4.9 since it now requires c++11. Thx ajacoutot for
the build-testing - note that it requires more than 4gb of memory to
build, and might not build on i386.
   2015-09-18 14:07:09 by Landry Breuil | Files touched by this commit (24)
Log message:
Update to mapnik 3.0.5.
Switch to use gcc 4.9 since it now requires c++11. Thx ajacoutot for
the build-testing - note that it requires more than 4gb of memory to
build, and might not build on i386.
   2015-09-18 14:07:09 by Landry Breuil | Files touched by this commit (24)
Log message:
Update to mapnik 3.0.5.
Switch to use gcc 4.9 since it now requires c++11. Thx ajacoutot for
the build-testing - note that it requires more than 4gb of memory to
build, and might not build on i386.
   2015-09-18 14:07:09 by Landry Breuil | Files touched by this commit (24)
Log message:
Update to mapnik 3.0.5.
Switch to use gcc 4.9 since it now requires c++11. Thx ajacoutot for
the build-testing - note that it requires more than 4gb of memory to
build, and might not build on i386.
   2015-09-18 14:07:09 by Landry Breuil | Files touched by this commit (24)
Log message:
Update to mapnik 3.0.5.
Switch to use gcc 4.9 since it now requires c++11. Thx ajacoutot for
the build-testing - note that it requires more than 4gb of memory to
build, and might not build on i386.
   2015-09-18 14:07:09 by Landry Breuil | Files touched by this commit (24)
Log message:
Update to mapnik 3.0.5.
Switch to use gcc 4.9 since it now requires c++11. Thx ajacoutot for
the build-testing - note that it requires more than 4gb of memory to
build, and might not build on i386.
   2015-09-18 14:07:09 by Landry Breuil | Files touched by this commit (24)
Log message:
Update to mapnik 3.0.5.
Switch to use gcc 4.9 since it now requires c++11. Thx ajacoutot for
the build-testing - note that it requires more than 4gb of memory to
build, and might not build on i386.
   2015-09-18 14:07:09 by Landry Breuil | Files touched by this commit (24)
Log message:
Update to mapnik 3.0.5.
Switch to use gcc 4.9 since it now requires c++11. Thx ajacoutot for
the build-testing - note that it requires more than 4gb of memory to
build, and might not build on i386.
   2015-09-18 14:07:09 by Landry Breuil | Files touched by this commit (24)
Log message:
Update to mapnik 3.0.5.
Switch to use gcc 4.9 since it now requires c++11. Thx ajacoutot for
the build-testing - note that it requires more than 4gb of memory to
build, and might not build on i386.
   2015-09-18 14:07:09 by Landry Breuil | Files touched by this commit (24)
Log message:
Update to mapnik 3.0.5.
Switch to use gcc 4.9 since it now requires c++11. Thx ajacoutot for
the build-testing - note that it requires more than 4gb of memory to
build, and might not build on i386.
   2015-09-18 14:07:09 by Landry Breuil | Files touched by this commit (24)
Log message:
Update to mapnik 3.0.5.
Switch to use gcc 4.9 since it now requires c++11. Thx ajacoutot for
the build-testing - note that it requires more than 4gb of memory to
build, and might not build on i386.
   2015-09-18 14:07:09 by Landry Breuil | Files touched by this commit (24)
Log message:
Update to mapnik 3.0.5.
Switch to use gcc 4.9 since it now requires c++11. Thx ajacoutot for
the build-testing - note that it requires more than 4gb of memory to
build, and might not build on i386.
   2015-09-18 14:07:09 by Landry Breuil | Files touched by this commit (24)
Log message:
Update to mapnik 3.0.5.
Switch to use gcc 4.9 since it now requires c++11. Thx ajacoutot for
the build-testing - note that it requires more than 4gb of memory to
build, and might not build on i386.
   2015-09-18 14:07:09 by Landry Breuil | Files touched by this commit (24)
Log message:
Update to mapnik 3.0.5.
Switch to use gcc 4.9 since it now requires c++11. Thx ajacoutot for
the build-testing - note that it requires more than 4gb of memory to
build, and might not build on i386.
   2015-09-18 14:07:09 by Landry Breuil | Files touched by this commit (24)
Log message:
Update to mapnik 3.0.5.
Switch to use gcc 4.9 since it now requires c++11. Thx ajacoutot for
the build-testing - note that it requires more than 4gb of memory to
build, and might not build on i386.
   2015-09-18 14:07:09 by Landry Breuil | Files touched by this commit (24)
Log message:
Update to mapnik 3.0.5.
Switch to use gcc 4.9 since it now requires c++11. Thx ajacoutot for
the build-testing - note that it requires more than 4gb of memory to
build, and might not build on i386.
   2015-09-18 14:07:09 by Landry Breuil | Files touched by this commit (24)
Log message:
Update to mapnik 3.0.5.
Switch to use gcc 4.9 since it now requires c++11. Thx ajacoutot for
the build-testing - note that it requires more than 4gb of memory to
build, and might not build on i386.
   2015-09-18 14:07:09 by Landry Breuil | Files touched by this commit (24)
Log message:
Update to mapnik 3.0.5.
Switch to use gcc 4.9 since it now requires c++11. Thx ajacoutot for
the build-testing - note that it requires more than 4gb of memory to
build, and might not build on i386.
   2015-09-18 14:07:09 by Landry Breuil | Files touched by this commit (24)
Log message:
Update to mapnik 3.0.5.
Switch to use gcc 4.9 since it now requires c++11. Thx ajacoutot for
the build-testing - note that it requires more than 4gb of memory to
build, and might not build on i386.
   2015-09-18 14:07:09 by Landry Breuil | Files touched by this commit (24)
Log message:
Update to mapnik 3.0.5.
Switch to use gcc 4.9 since it now requires c++11. Thx ajacoutot for
the build-testing - note that it requires more than 4gb of memory to
build, and might not build on i386.
   2015-09-18 14:07:09 by Landry Breuil | Files touched by this commit (24)
Log message:
Update to mapnik 3.0.5.
Switch to use gcc 4.9 since it now requires c++11. Thx ajacoutot for
the build-testing - note that it requires more than 4gb of memory to
build, and might not build on i386.
   2015-09-18 14:07:09 by Landry Breuil | Files touched by this commit (24)
Log message:
Update to mapnik 3.0.5.
Switch to use gcc 4.9 since it now requires c++11. Thx ajacoutot for
the build-testing - note that it requires more than 4gb of memory to
build, and might not build on i386.
   2015-09-18 14:07:09 by Landry Breuil | Files touched by this commit (24)
Log message:
Update to mapnik 3.0.5.
Switch to use gcc 4.9 since it now requires c++11. Thx ajacoutot for
the build-testing - note that it requires more than 4gb of memory to
build, and might not build on i386.
   2015-09-18 14:07:09 by Landry Breuil | Files touched by this commit (24)
Log message:
Update to mapnik 3.0.5.
Switch to use gcc 4.9 since it now requires c++11. Thx ajacoutot for
the build-testing - note that it requires more than 4gb of memory to
build, and might not build on i386.
   2015-07-01 02:45:19 by Jasper Lievisse Adriaanse | Files touched by this commit (17)
Log message:
- lots of fixes from upstream to build with new boost/phoenix v3 (from upstream)
- bump boost dependency
ok landry@ (MAINTAINER)
   2015-07-01 02:45:19 by Jasper Lievisse Adriaanse | Files touched by this commit (17)
Log message:
- lots of fixes from upstream to build with new boost/phoenix v3 (from upstream)
- bump boost dependency
ok landry@ (MAINTAINER)
   2015-07-01 02:45:19 by Jasper Lievisse Adriaanse | Files touched by this commit (17)
Log message:
- lots of fixes from upstream to build with new boost/phoenix v3 (from upstream)
- bump boost dependency
ok landry@ (MAINTAINER)
   2015-07-01 02:45:19 by Jasper Lievisse Adriaanse | Files touched by this commit (17)
Log message:
- lots of fixes from upstream to build with new boost/phoenix v3 (from upstream)
- bump boost dependency
ok landry@ (MAINTAINER)
   2015-07-01 02:45:19 by Jasper Lievisse Adriaanse | Files touched by this commit (17)
Log message:
- lots of fixes from upstream to build with new boost/phoenix v3 (from upstream)
- bump boost dependency
ok landry@ (MAINTAINER)
   2015-07-01 02:45:19 by Jasper Lievisse Adriaanse | Files touched by this commit (17)
Log message:
- lots of fixes from upstream to build with new boost/phoenix v3 (from upstream)
- bump boost dependency
ok landry@ (MAINTAINER)
   2015-07-01 02:45:19 by Jasper Lievisse Adriaanse | Files touched by this commit (17)
Log message:
- lots of fixes from upstream to build with new boost/phoenix v3 (from upstream)
- bump boost dependency
ok landry@ (MAINTAINER)
   2015-07-01 02:45:19 by Jasper Lievisse Adriaanse | Files touched by this commit (17)
Log message:
- lots of fixes from upstream to build with new boost/phoenix v3 (from upstream)
- bump boost dependency
ok landry@ (MAINTAINER)
   2015-07-01 02:45:19 by Jasper Lievisse Adriaanse | Files touched by this commit (17)
Log message:
- lots of fixes from upstream to build with new boost/phoenix v3 (from upstream)
- bump boost dependency
ok landry@ (MAINTAINER)
   2015-07-01 02:45:19 by Jasper Lievisse Adriaanse | Files touched by this commit (17)
Log message:
- lots of fixes from upstream to build with new boost/phoenix v3 (from upstream)
- bump boost dependency
ok landry@ (MAINTAINER)
   2015-07-01 02:45:19 by Jasper Lievisse Adriaanse | Files touched by this commit (17)
Log message:
- lots of fixes from upstream to build with new boost/phoenix v3 (from upstream)
- bump boost dependency
ok landry@ (MAINTAINER)
   2015-07-01 02:45:19 by Jasper Lievisse Adriaanse | Files touched by this commit (17)
Log message:
- lots of fixes from upstream to build with new boost/phoenix v3 (from upstream)
- bump boost dependency
ok landry@ (MAINTAINER)
   2015-07-01 02:45:19 by Jasper Lievisse Adriaanse | Files touched by this commit (17)
Log message:
- lots of fixes from upstream to build with new boost/phoenix v3 (from upstream)
- bump boost dependency
ok landry@ (MAINTAINER)
   2015-07-01 02:45:19 by Jasper Lievisse Adriaanse | Files touched by this commit (17)
Log message:
- lots of fixes from upstream to build with new boost/phoenix v3 (from upstream)
- bump boost dependency
ok landry@ (MAINTAINER)
   2015-07-01 02:45:19 by Jasper Lievisse Adriaanse | Files touched by this commit (17)
Log message:
- lots of fixes from upstream to build with new boost/phoenix v3 (from upstream)
- bump boost dependency
ok landry@ (MAINTAINER)
   2015-07-01 02:45:19 by Jasper Lievisse Adriaanse | Files touched by this commit (17)
Log message:
- lots of fixes from upstream to build with new boost/phoenix v3 (from upstream)
- bump boost dependency
ok landry@ (MAINTAINER)
   2015-07-01 02:45:19 by Jasper Lievisse Adriaanse | Files touched by this commit (17)
Log message:
- lots of fixes from upstream to build with new boost/phoenix v3 (from upstream)
- bump boost dependency
ok landry@ (MAINTAINER)
   2015-06-27 00:56:57 by Landry Breuil | Files touched by this commit (1)
Log message:
Backport an upstream commit to fix build against gdal 2.0.0 API.
(Note that mapnik3 is in release candidate state...)
   2015-05-05 11:00:21 by Stuart Henderson | Files touched by this commit (152)
Log message:
sync WANTLIB
   2011-07-08 14:38:02 by Christian Weisgerber | Files touched by this commit (91)
Log message:
Fix build with png-1.5.
All fixes by yours truly.
   2011-06-08 11:35:28 by Jasper Lievisse Adriaanse | Files touched by this commit (19)
Log message:
bump after default python version switch
   2011-05-13 08:58:36 by Antoine Jacoutot | Files touched by this commit (1)
Log message:
landry, stop adding your build logs in the ports tree ;)
   2010-11-17 01:05:18 by Marc Espie | Files touched by this commit (317)
Log message:
new depends