./print/foomatic-db-engine [Foomatic PPD generator]
[+] Add this package to your ports tracker

[ CVSweb ] [ Homepage ] [ RSS feed ]

Version: 4.0.12, Package name: foomatic-db-engine-4.0.12
Maintained by: Antoine Jacoutot
Master sites:
Description
Foomatic's database engine generates PPD files from the data in
Foomatic's XML database. It also contains scripts to directly generate
print queues and handle jobs.


Filesize: 352.05 KB
Version History (View Complete History)
  • (2015-02-15) Updated to version: foomatic-db-engine-4.0.12
  • (2014-03-24) Updated to version: foomatic-db-engine-4.0.11
  • (2014-03-18) Updated to version: foomatic-db-engine-4.0.10
  • (2013-03-23) Updated to version: foomatic-db-engine-4.0.9
  • (2011-09-05) Updated to version: foomatic-db-engine-4.0.8
  • (2011-05-15) Updated to version: foomatic-db-engine-4.0.7
  • (2010-11-14) Package deleted from Ports
  • (2010-08-22) Updated to version: foomatic-db-engine-4.0.5
  • (2010-03-21) Updated to version: foomatic-db-engine-4.0.4
  • (2010-01-12) Updated to version: foomatic-db-engine-4.0.3p0
[show/hide] View available PLISTS (Can be a lot of data)

CVS Commit History:

   2016-11-08 07:23:59 by Stuart Henderson | Files touched by this commit (10)
Log message:
WANTLIB += lzma and bump
   2016-09-13 12:52:06 by Christian Weisgerber | Files touched by this commit (23)
Log message:
replace libiconv module
   2015-04-21 12:24:23 by Stuart Henderson | Files touched by this commit (32)
Log message:
add some missing pthread to WANTLIB
(using modified portbump, thanks zhuk@)
   2015-02-16 15:57:14 by Christian Weisgerber | Files touched by this commit (213)
Log message:
Drop USE_GROFF from ports where the formatting differences are acceptable
or mandoc provides the more useful output.
   2015-02-15 01:00:01 by Antoine Jacoutot | Files touched by this commit (3)
Log message:
Update to foomatic-db-engine-4.0.12.
   2015-02-15 01:00:01 by Antoine Jacoutot | Files touched by this commit (3)
Log message:
Update to foomatic-db-engine-4.0.12.
   2015-02-15 01:00:01 by Antoine Jacoutot | Files touched by this commit (3)
Log message:
Update to foomatic-db-engine-4.0.12.
   2011-06-02 07:41:42 by Antoine Jacoutot | Files touched by this commit (238)
Log message:
Add a consistent header that substitutes FULLPKGNAME for the READMEs.
ok jasper@ sthen@
   2011-04-15 12:50:06 by Antoine Jacoutot | Files touched by this commit (5)
Log message:
Update to foomatic-db-engine-4.0.7.
   2011-04-15 12:50:06 by Antoine Jacoutot | Files touched by this commit (5)
Log message:
Update to foomatic-db-engine-4.0.7.
   2011-04-15 12:50:06 by Antoine Jacoutot | Files touched by this commit (5)
Log message:
Update to foomatic-db-engine-4.0.7.
   2011-04-15 12:50:06 by Antoine Jacoutot | Files touched by this commit (5)
Log message:
Update to foomatic-db-engine-4.0.7.
   2011-04-15 12:50:06 by Antoine Jacoutot | Files touched by this commit (5)
Log message:
Update to foomatic-db-engine-4.0.7.
   2011-04-15 12:40:47 by Antoine Jacoutot | Files touched by this commit (6)
Log message:
Rework the way we handle dependencies in the print ports:
* depends on foomatic-filters when a driver installs:
share/foomatic/db/source/.../*.ppd{,.gz}
* depends on foomatic-db-engine when a driver installs:
share/foomatic/db/source/.../*.xml
foomatic-db-engine now depends on foomatic-db (which itself depends on
nothing anymore).
This will ensure all the needed packages are installed for complete
foomatic-* use.
Some packages install both pre-created ppd and xml files, so theorically
it wouldn't need to depend on foomatic-db-engine, but we still do it
because we may want to regen the ppd file.
It's the best compromise I could come up with.
   2011-01-02 00:32:08 by Antoine Jacoutot | Files touched by this commit (2)
Log message:
Bugfix update to foomatic-db-engine-4.0.6.
   2011-01-02 00:32:08 by Antoine Jacoutot | Files touched by this commit (2)
Log message:
Bugfix update to foomatic-db-engine-4.0.6.
   2010-11-20 02:48:40 by Marc Espie | Files touched by this commit (96)
Log message:
new depends
   2010-11-13 02:48:42 by Antoine Jacoutot | Files touched by this commit (4)
Log message:
Move big MESSAGE into a README.
   2010-11-13 02:48:42 by Antoine Jacoutot | Files touched by this commit (4)
Log message:
Move big MESSAGE into a README.
   2010-11-13 02:48:42 by Antoine Jacoutot | Files touched by this commit (4)
Log message:
Move big MESSAGE into a README.
   2010-11-13 02:48:42 by Antoine Jacoutot | Files touched by this commit (4)
Log message:
Move big MESSAGE into a README.
   2010-10-18 15:25:09 by Marc Espie | Files touched by this commit (100)
Log message:
USE_GROFF=Yes
   2010-08-22 00:57:00 by Antoine Jacoutot | Files touched by this commit (4)
Log message:
Update to foomatic-db-engine-4.0.5.
   2010-08-22 00:57:00 by Antoine Jacoutot | Files touched by this commit (4)
Log message:
Update to foomatic-db-engine-4.0.5.
   2010-08-22 00:57:00 by Antoine Jacoutot | Files touched by this commit (4)
Log message:
Update to foomatic-db-engine-4.0.5.
   2010-08-22 00:57:00 by Antoine Jacoutot | Files touched by this commit (4)
Log message:
Update to foomatic-db-engine-4.0.5.
   2010-07-26 14:07:31 by Edd Barrett | Files touched by this commit (17)
Log message:
Convert a whole bunch of ports/print to use new WANTLIB/LIB_DEPENDS/REVISION.
OK aja@
   2010-03-21 08:41:00 by Antoine Jacoutot | Files touched by this commit (4)
Log message:
Update to foomatic-db-engine-4.0.4.
The important part for us is that "it is not required any more that for
Foomatic to return a PPD file for a given printer/driver combo that
there is an XML file for both the printer and the driver. One XML file
(either printer or driver) is enough when this file describes the
printer/driver relation."
That means that printers that did not appear before (i.e. one could not
create a custom ppd) where they were marked as supported will now
appear and work fine.
   2010-03-21 08:41:00 by Antoine Jacoutot | Files touched by this commit (4)
Log message:
Update to foomatic-db-engine-4.0.4.
The important part for us is that "it is not required any more that for
Foomatic to return a PPD file for a given printer/driver combo that
there is an XML file for both the printer and the driver. One XML file
(either printer or driver) is enough when this file describes the
printer/driver relation."
That means that printers that did not appear before (i.e. one could not
create a custom ppd) where they were marked as supported will now
appear and work fine.
   2010-03-21 08:41:00 by Antoine Jacoutot | Files touched by this commit (4)
Log message:
Update to foomatic-db-engine-4.0.4.
The important part for us is that "it is not required any more that for
Foomatic to return a PPD file for a given printer/driver combo that
there is an XML file for both the printer and the driver. One XML file
(either printer or driver) is enough when this file describes the
printer/driver relation."
That means that printers that did not appear before (i.e. one could not
create a custom ppd) where they were marked as supported will now
appear and work fine.
   2010-03-21 08:41:00 by Antoine Jacoutot | Files touched by this commit (4)
Log message:
Update to foomatic-db-engine-4.0.4.
The important part for us is that "it is not required any more that for
Foomatic to return a PPD file for a given printer/driver combo that
there is an XML file for both the printer and the driver. One XML file
(either printer or driver) is enough when this file describes the
printer/driver relation."
That means that printers that did not appear before (i.e. one could not
create a custom ppd) where they were marked as supported will now
appear and work fine.
   2010-01-12 03:59:00 by Antoine Jacoutot | Files touched by this commit (2)
Log message:
Tweak MESSAGE.
   2010-01-12 03:59:00 by Antoine Jacoutot | Files touched by this commit (2)
Log message:
Tweak MESSAGE.
   2009-12-10 03:57:59 by Antoine Jacoutot | Files touched by this commit (6)
Log message:
Update to foomatic-db-engine-4.0.3.
Add a link from foomatic-ppdfile  to the CUPS driver directory so that
PPDs file will be created on demand (no need to hunt for them on
openprinting.org).
Merge MESSAGE from foomatic-db-gutenprint to be more coherent.
Rework dependencies:
foomatic-db{gutenprint,hpijs}->foomatic-db->foomatic-db-engine
   2009-12-10 03:57:59 by Antoine Jacoutot | Files touched by this commit (6)
Log message:
Update to foomatic-db-engine-4.0.3.
Add a link from foomatic-ppdfile  to the CUPS driver directory so that
PPDs file will be created on demand (no need to hunt for them on
openprinting.org).
Merge MESSAGE from foomatic-db-gutenprint to be more coherent.
Rework dependencies:
foomatic-db{gutenprint,hpijs}->foomatic-db->foomatic-db-engine
   2009-12-10 03:57:59 by Antoine Jacoutot | Files touched by this commit (6)
Log message:
Update to foomatic-db-engine-4.0.3.
Add a link from foomatic-ppdfile  to the CUPS driver directory so that
PPDs file will be created on demand (no need to hunt for them on
openprinting.org).
Merge MESSAGE from foomatic-db-gutenprint to be more coherent.
Rework dependencies:
foomatic-db{gutenprint,hpijs}->foomatic-db->foomatic-db-engine
   2009-12-10 03:57:59 by Antoine Jacoutot | Files touched by this commit (6)
Log message:
Update to foomatic-db-engine-4.0.3.
Add a link from foomatic-ppdfile  to the CUPS driver directory so that
PPDs file will be created on demand (no need to hunt for them on
openprinting.org).
Merge MESSAGE from foomatic-db-gutenprint to be more coherent.
Rework dependencies:
foomatic-db{gutenprint,hpijs}->foomatic-db->foomatic-db-engine
   2009-12-10 03:57:59 by Antoine Jacoutot | Files touched by this commit (6)
Log message:
Update to foomatic-db-engine-4.0.3.
Add a link from foomatic-ppdfile  to the CUPS driver directory so that
PPDs file will be created on demand (no need to hunt for them on
openprinting.org).
Merge MESSAGE from foomatic-db-gutenprint to be more coherent.
Rework dependencies:
foomatic-db{gutenprint,hpijs}->foomatic-db->foomatic-db-engine
   2009-12-10 03:57:59 by Antoine Jacoutot | Files touched by this commit (6)
Log message:
Update to foomatic-db-engine-4.0.3.
Add a link from foomatic-ppdfile  to the CUPS driver directory so that
PPDs file will be created on demand (no need to hunt for them on
openprinting.org).
Merge MESSAGE from foomatic-db-gutenprint to be more coherent.
Rework dependencies:
foomatic-db{gutenprint,hpijs}->foomatic-db->foomatic-db-engine
   2008-12-20 14:15:56 by Antoine Jacoutot | Files touched by this commit (5)
Log message:
- take maintainership of these ports, jacob@ is on audio now and not
printing anymore ;-)
"go ahead" jacob@
   2008-09-18 07:37:41 by Antoine Jacoutot | Files touched by this commit (20)
Log message:
- SYSCONFDIR and LOCALBASE are already part of the generic SUBST_VARS
looks good to landry@
   2007-10-27 17:44:41 by Antoine Jacoutot | Files touched by this commit (12)
Log message:
- domain name change; fix MASTER_SITES
   2007-09-26 02:25:34 by Antoine Jacoutot | Files touched by this commit (7)
Log message:
- update to foomatic-db-engine-3.0.20070919 for better support of newer
PPDs (also resolve a parsing bug on powerpc)
- use a saner version number
- fix default libdir
ok jakemsr@
   2007-09-26 02:25:34 by Antoine Jacoutot | Files touched by this commit (7)
Log message:
- update to foomatic-db-engine-3.0.20070919 for better support of newer
PPDs (also resolve a parsing bug on powerpc)
- use a saner version number
- fix default libdir
ok jakemsr@
   2007-09-26 02:25:34 by Antoine Jacoutot | Files touched by this commit (7)
Log message:
- update to foomatic-db-engine-3.0.20070919 for better support of newer
PPDs (also resolve a parsing bug on powerpc)
- use a saner version number
- fix default libdir
ok jakemsr@
   2007-09-26 02:25:34 by Antoine Jacoutot | Files touched by this commit (7)
Log message:
- update to foomatic-db-engine-3.0.20070919 for better support of newer
PPDs (also resolve a parsing bug on powerpc)
- use a saner version number
- fix default libdir
ok jakemsr@
   2007-09-26 02:25:34 by Antoine Jacoutot | Files touched by this commit (7)
Log message:
- update to foomatic-db-engine-3.0.20070919 for better support of newer
PPDs (also resolve a parsing bug on powerpc)
- use a saner version number
- fix default libdir
ok jakemsr@
   2007-09-26 02:25:34 by Antoine Jacoutot | Files touched by this commit (7)
Log message:
- update to foomatic-db-engine-3.0.20070919 for better support of newer
PPDs (also resolve a parsing bug on powerpc)
- use a saner version number
- fix default libdir
ok jakemsr@
   2007-09-26 02:25:34 by Antoine Jacoutot | Files touched by this commit (7)
Log message:
- update to foomatic-db-engine-3.0.20070919 for better support of newer
PPDs (also resolve a parsing bug on powerpc)
- use a saner version number
- fix default libdir
ok jakemsr@