./security/john-jumbo [extremely fast password cracker, with community patches]
[+] Add this package to your ports tracker

[ CVSweb ] [ Homepage ] [ RSS feed ]

Version: 1.8.0.1, Package name: john-jumbo-1.8.0.1
Maintained by: The OpenBSD ports mailing-list
Master sites:
Description
John the Ripper is a fast and powerful password cracker. It combines several
cracking modes in one program, and is fully configurable for your particular
needs (you can even define a custom cracking mode using the built-in compiler
supporting a subset of C).

Out of the box, John supports (and autodetects) the following crypt formats:
standard and double-length DES-based, BSDI's extended DES-based, FreeBSD's
MD5-based and OpenBSD's Blowfish-based.

This package includes the "jumbo" patch of community enhancements, including
support for many additional hash and cipher types (including popular ones
such as NTLM, raw MD5, etc., and even things such as encrypted OpenSSH
private keys, ZIP and RAR archives, PDF files, etc.), as well as some
optimizations and features.


Filesize: 22687.98 KB
Version History (View Complete History)
  • (2015-01-16) Updated to version: john-jumbo-1.8.0.1
  • (2014-06-04) Updated to version: john-jumbo-1.8.0pre20140604
  • (2014-06-03) Package added to openports.se, version john-jumbo-1.7.9pl7 (created)
[show/hide] View available PLISTS (Can be a lot of data)

CVS Commit History:

   2016-12-31 11:24:08 by Jeremie Courreges-Anglas | Files touched by this commit (1)
Log message:
Mark as BROKEN on arm, stray '$' in program
   2016-09-23 03:16:58 by Stuart Henderson | Files touched by this commit (124)
Log message:
Cope with moving sqlite3 back to ports.
   2016-09-01 04:53:27 by Jasper Lievisse Adriaanse | Files touched by this commit (36)
Log message:
retire sparc
   2016-03-09 11:31:36 by Jasper Lievisse Adriaanse | Files touched by this commit (14)
Log message:
remove vax workarounds/tentacles, reword where applicable
   2015-09-16 06:10:34 by Stuart Henderson | Files touched by this commit (1)
Log message:
better comment
   2015-09-16 05:32:28 by Stuart Henderson | Files touched by this commit (1)
Log message:
don't build rawSHA0_fmt_plug.c, it relies on libcrypto code which has
been zapped.
   2015-01-18 04:57:22 by Stuart Henderson | Files touched by this commit (6)
Log message:
/usr/include/crypto/des.h was removed as well as /usr/include/des.h
   2015-01-18 04:57:22 by Stuart Henderson | Files touched by this commit (6)
Log message:
/usr/include/crypto/des.h was removed as well as /usr/include/des.h
   2015-01-18 04:57:22 by Stuart Henderson | Files touched by this commit (6)
Log message:
/usr/include/crypto/des.h was removed as well as /usr/include/des.h
   2015-01-18 04:57:22 by Stuart Henderson | Files touched by this commit (6)
Log message:
/usr/include/crypto/des.h was removed as well as /usr/include/des.h
   2015-01-18 04:57:22 by Stuart Henderson | Files touched by this commit (6)
Log message:
/usr/include/crypto/des.h was removed as well as /usr/include/des.h
   2015-01-18 04:57:22 by Stuart Henderson | Files touched by this commit (6)
Log message:
/usr/include/crypto/des.h was removed as well as /usr/include/des.h
   2015-01-17 07:39:52 by Stuart Henderson | Files touched by this commit (1)
Log message:
add a patch from john-jumbo git to fix build on !amd64
   2015-01-16 08:40:01 by Stuart Henderson | Files touched by this commit (14)
Log message:
update to john-jumbo 1.80-1
   2015-01-16 08:40:01 by Stuart Henderson | Files touched by this commit (14)
Log message:
update to john-jumbo 1.80-1
   2015-01-16 08:40:01 by Stuart Henderson | Files touched by this commit (14)
Log message:
update to john-jumbo 1.80-1
   2015-01-16 08:40:01 by Stuart Henderson | Files touched by this commit (14)
Log message:
update to john-jumbo 1.80-1
   2015-01-16 08:40:01 by Stuart Henderson | Files touched by this commit (14)
Log message:
update to john-jumbo 1.80-1
   2015-01-16 08:40:01 by Stuart Henderson | Files touched by this commit (14)
Log message:
update to john-jumbo 1.80-1
   2015-01-16 08:40:01 by Stuart Henderson | Files touched by this commit (14)
Log message:
update to john-jumbo 1.80-1
   2015-01-16 08:40:01 by Stuart Henderson | Files touched by this commit (14)
Log message:
update to john-jumbo 1.80-1
   2015-01-16 08:40:01 by Stuart Henderson | Files touched by this commit (14)
Log message:
update to john-jumbo 1.80-1
   2015-01-16 08:40:01 by Stuart Henderson | Files touched by this commit (14)
Log message:
update to john-jumbo 1.80-1
   2015-01-16 08:40:01 by Stuart Henderson | Files touched by this commit (14)
Log message:
update to john-jumbo 1.80-1
   2015-01-16 08:40:01 by Stuart Henderson | Files touched by this commit (14)
Log message:
update to john-jumbo 1.80-1
   2015-01-16 08:40:01 by Stuart Henderson | Files touched by this commit (14)
Log message:
update to john-jumbo 1.80-1
   2015-01-16 08:40:01 by Stuart Henderson | Files touched by this commit (14)
Log message:
update to john-jumbo 1.80-1
   2015-01-16 08:02:23 by Stuart Henderson | Files touched by this commit (5)
Log message:
adjust security/john-jumbo patches to avoid relying on des.h
   2015-01-16 08:02:23 by Stuart Henderson | Files touched by this commit (5)
Log message:
adjust security/john-jumbo patches to avoid relying on des.h
   2015-01-16 08:02:23 by Stuart Henderson | Files touched by this commit (5)
Log message:
adjust security/john-jumbo patches to avoid relying on des.h
   2015-01-16 08:02:23 by Stuart Henderson | Files touched by this commit (5)
Log message:
adjust security/john-jumbo patches to avoid relying on des.h
   2015-01-16 08:02:23 by Stuart Henderson | Files touched by this commit (5)
Log message:
adjust security/john-jumbo patches to avoid relying on des.h
   2014-12-30 14:50:25 by Landry Breuil | Files touched by this commit (15)
Log message:
Mark BROKEN-alpha a bunch of ports that reliably failed (!) to build in
the past 3 bulks, or forever.
Various reasons: no d^Hrecent compiler available, base gcc generating
nice internal compiler errors, no atomic ops, etc, etc.
While here, mark all webkits as BROKEN-hppa, since this also requires
clang or g++ 4.7. Our g++ 4.8 port only builds on
i386|amd64|powerpc|sparc64 anyway...
if you're interested^Wbored to death, full past logs at
http://build-failures.rhaalovely.net/alpha/...