./www/ruby-capybara-webkit [capybara driver that uses WebKit]
[+] Add this package to your ports tracker

[ CVSweb ] [ Homepage ] [ RSS feed ]

Version: 1.14.0, Package name: capybara-webkit-1.14.0
Maintained by: The OpenBSD ports mailing-list
Master sites:
Flavors (export FLAVOR=xyz, setenv FLAVOR xyz):
  • ruby23
  • ruby24
Description
Capybara driver that uses WebKit via QtWebKit.


Filesize: 93.5 KB
Version History (View Complete History)
  • (2017-11-04) Updated to version: capybara-webkit-1.14.0
  • (2016-09-23) Updated to version: capybara-webkit-1.11.1
  • (2015-07-26) Updated to version: capybara-webkit-1.6.0
  • (2015-04-02) Updated to version: capybara-webkit-1.5.0
  • (2012-12-20) Package added to openports.se, version capybara-webkit-0.13.0 (created)
[show/hide] View available PLISTS (Can be a lot of data)

CVS Commit History:

   2017-07-30 08:57:00 by Marc Espie | Files touched by this commit (1)
Log message:
bump
   2017-07-26 16:45:35 by Stuart Henderson | Files touched by this commit (937)
Log message:
bump LIBCXX/LIBECXX/COMPILER_LIBCXX ports.
   2017-07-16 13:19:06 by Marc Espie | Files touched by this commit (880)
Log message:
use COMPILER_LIBCXX where applicable
   2017-06-05 17:55:19 by Jeremy Evans | Files touched by this commit (2)
Log message:
Unbreak by switching to gcc4 module, which supports -std=gnu++0x
Additionally, patch out support to precompile headers.
   2017-06-05 17:55:19 by Jeremy Evans | Files touched by this commit (2)
Log message:
Unbreak by switching to gcc4 module, which supports -std=gnu++0x
Additionally, patch out support to precompile headers.
   2017-05-26 09:43:18 by Antoine Jacoutot | Files touched by this commit (1)
Log message:
Temporarily mark BROKEN until jca@ has time to look at this new breakage.
   2017-05-15 14:53:33 by Marc Espie | Files touched by this commit (1)
Log message:
fix nonsense, you can't run-depend on qt5
   2017-04-10 05:46:37 by Stuart Henderson | Files touched by this commit (277)
Log message:
use LIBCXX
   2016-12-25 07:34:40 by Vadim Zhukov | Files touched by this commit (43)
Log message:
Adapt to new x11/qt5 layout, mostly REVISION bumps due to changed deps.
The devel/kf5 to be handled separately, please wait.
   2016-11-04 15:26:38 by Jeremy Evans | Files touched by this commit (27)
Log message:
Bump ruby gem ext ports after change to PLISTs
This does not include all ruby gem ext ports, but the remaining ones have
updates that will be committed separately.
   2016-09-23 09:25:23 by Jeremy Evans | Files touched by this commit (4)
Log message:
Update to capybara-webkit 1.11.1
Set USE_WXNEEDED, as the webkit_server executable uses W|X code.
Also set LDFLAGS to make sure wxneeded is set by the linker.
Add a patch to the qmake file so that LDFLAGS, CFLAGS, and
CXXFLAGS are respected.
   2016-09-23 09:25:23 by Jeremy Evans | Files touched by this commit (4)
Log message:
Update to capybara-webkit 1.11.1
Set USE_WXNEEDED, as the webkit_server executable uses W|X code.
Also set LDFLAGS to make sure wxneeded is set by the linker.
Add a patch to the qmake file so that LDFLAGS, CFLAGS, and
CXXFLAGS are respected.
   2016-09-23 09:25:23 by Jeremy Evans | Files touched by this commit (4)
Log message:
Update to capybara-webkit 1.11.1
Set USE_WXNEEDED, as the webkit_server executable uses W|X code.
Also set LDFLAGS to make sure wxneeded is set by the linker.
Add a patch to the qmake file so that LDFLAGS, CFLAGS, and
CXXFLAGS are respected.
   2016-09-23 09:25:23 by Jeremy Evans | Files touched by this commit (4)
Log message:
Update to capybara-webkit 1.11.1
Set USE_WXNEEDED, as the webkit_server executable uses W|X code.
Also set LDFLAGS to make sure wxneeded is set by the linker.
Add a patch to the qmake file so that LDFLAGS, CFLAGS, and
CXXFLAGS are respected.
   2015-07-25 21:20:01 by Jeremy Evans | Files touched by this commit (3)
Log message:
Update to capybara-webkit 1.6.0
   2015-07-25 21:20:01 by Jeremy Evans | Files touched by this commit (3)
Log message:
Update to capybara-webkit 1.6.0
   2015-07-25 21:20:01 by Jeremy Evans | Files touched by this commit (3)
Log message:
Update to capybara-webkit 1.6.0
   2015-07-18 09:46:12 by Jeremy Evans | Files touched by this commit (8)
Log message:
Remove unnecessary dependency on ruby-json.
The json library is shipped with ruby 1.9+, and these ports support the
json library that comes with ruby.  While here, remove some
MODRUBY_ICONV_DEPENDS as those only are necessary on ruby 1.8.
OK jasper@
   2015-04-01 14:55:45 by Jeremy Evans | Files touched by this commit (6)
Log message:
Update to capybara-webkit 1.5.0
Switch to using qt5 instead of qt4, as upstream is planning on dropping
qt4 support.  Remove local patches, now included upstream.
Thanks to Mike Burns and Matt Horan for feedback and getting the
changes applied upstream.
   2015-04-01 14:55:45 by Jeremy Evans | Files touched by this commit (6)
Log message:
Update to capybara-webkit 1.5.0
Switch to using qt5 instead of qt4, as upstream is planning on dropping
qt4 support.  Remove local patches, now included upstream.
Thanks to Mike Burns and Matt Horan for feedback and getting the
changes applied upstream.
   2015-04-01 14:55:45 by Jeremy Evans | Files touched by this commit (6)
Log message:
Update to capybara-webkit 1.5.0
Switch to using qt5 instead of qt4, as upstream is planning on dropping
qt4 support.  Remove local patches, now included upstream.
Thanks to Mike Burns and Matt Horan for feedback and getting the
changes applied upstream.
   2015-04-01 14:55:45 by Jeremy Evans | Files touched by this commit (6)
Log message:
Update to capybara-webkit 1.5.0
Switch to using qt5 instead of qt4, as upstream is planning on dropping
qt4 support.  Remove local patches, now included upstream.
Thanks to Mike Burns and Matt Horan for feedback and getting the
changes applied upstream.
   2015-04-01 14:55:45 by Jeremy Evans | Files touched by this commit (6)
Log message:
Update to capybara-webkit 1.5.0
Switch to using qt5 instead of qt4, as upstream is planning on dropping
qt4 support.  Remove local patches, now included upstream.
Thanks to Mike Burns and Matt Horan for feedback and getting the
changes applied upstream.
   2015-04-01 14:55:45 by Jeremy Evans | Files touched by this commit (6)
Log message:
Update to capybara-webkit 1.5.0
Switch to using qt5 instead of qt4, as upstream is planning on dropping
qt4 support.  Remove local patches, now included upstream.
Thanks to Mike Burns and Matt Horan for feedback and getting the
changes applied upstream.