NOTICE: This package no longer exists in Ports


./x11/gnome/py-gnome-extras [additional Python bindings for GNOME]

[ CVSweb ] [ Homepage ] [ RSS feed ]

Version: 2.25.3, Package name: py-gnome-extras-2.25.3
Maintained by: Jasper Lievisse Adriaanse, Antoine Jacoutot
Master sites:
Description
py-gnome-extras (also known as gnome-python-extras) is a set of bindings
for the GNOME platform libraries. It extends py-gnome with bindings for
several libraries.

Currently covered parts are:
- gtkhtml2
- egg.trayicon
- egg.recent
- gtkmozembed
- gtkspell
- gdl
- gda
- gksu2
- gksu.ui


MD5: nzt+xcVxMLlgYctIa3nAdg=
RMD160: 4JvAFSUS4sqmFian3HiNczbyTkY=
Filesize: 361.806 KB

Package available on: cdrom(), ftp()
Distfile available on: cdrom(), ftp()

Version History (View Complete History)
  • (2010-04-25) Updated to version: py-gnome-extras-2.25.3p5
  • (2010-04-21) Updated to version: py-gnome-extras-2.25.3p4
  • (2010-04-04) Updated to version: py-gnome-extras-2.25.3p3
  • (2009-11-24) Updated to version: py-gnome-extras-2.25.3p2
  • (2009-10-15) Updated to version: py-gnome-extras-2.25.3p1
  • (2009-10-15) Updated to version: py-gnome-extras-2.25.3p0
  • (2009-08-11) Updated to version: py-gnome-extras-2.19.1p11
  • (2009-07-28) Updated to version: py-gnome-extras-2.19.1p10
  • (2009-06-25) Updated to version: py-gnome-extras-2.19.1p9
  • (2009-03-29) Updated to version: py-gnome-extras-2.19.1p8
[show/hide] View available PLISTS (Can be a lot of data)

CVS Commit History:

   2011-07-20 00:34:48 by Antoine Jacoutot | Files touched by this commit (8)
Log message:
Remove, not used by anything in tree and will ease the future gnome3 merge.
ok jasper@
   2011-07-20 00:34:48 by Antoine Jacoutot | Files touched by this commit (8)
Log message:
Remove, not used by anything in tree and will ease the future gnome3 merge.
ok jasper@
   2011-07-20 00:34:48 by Antoine Jacoutot | Files touched by this commit (8)
Log message:
Remove, not used by anything in tree and will ease the future gnome3 merge.
ok jasper@
   2011-07-20 00:34:48 by Antoine Jacoutot | Files touched by this commit (8)
Log message:
Remove, not used by anything in tree and will ease the future gnome3 merge.
ok jasper@
   2011-07-20 00:34:48 by Antoine Jacoutot | Files touched by this commit (8)
Log message:
Remove, not used by anything in tree and will ease the future gnome3 merge.
ok jasper@
   2011-07-20 00:34:48 by Antoine Jacoutot | Files touched by this commit (8)
Log message:
Remove, not used by anything in tree and will ease the future gnome3 merge.
ok jasper@
   2011-07-20 00:34:48 by Antoine Jacoutot | Files touched by this commit (8)
Log message:
Remove, not used by anything in tree and will ease the future gnome3 merge.
ok jasper@
   2011-07-20 00:34:48 by Antoine Jacoutot | Files touched by this commit (8)
Log message:
Remove, not used by anything in tree and will ease the future gnome3 merge.
ok jasper@
   2011-06-08 11:41:58 by Remi Pointel | Files touched by this commit (48)
Log message:
bump after default python version switch.
   2011-05-03 13:27:54 by Landry Breuil | Files touched by this commit (1)
Log message:
Fix WANTLIB after last py-gnome commit to fix packaging.
   2011-03-08 23:23:36 by Antoine Jacoutot | Files touched by this commit (8)
Log message:
Use FULLPKGNAME in REGRESS_DEPENDS, much less error-prone.
   2010-11-22 01:37:07 by Marc Espie | Files touched by this commit (859)
Log message:
new depends
   2010-10-24 09:53:56 by Stuart Henderson | Files touched by this commit (36)
Log message:
Add MODPY_WANTLIB, adjust MODPY_LIB_DEPENDS to new-style LIB_DEPENDS,
update all ports to match. Plists don't change -> no bump.
Looks ok to jasper.
   2010-10-18 07:18:16 by Jasper Lievisse Adriaanse | Files touched by this commit (92)
Log message:
- remove USE_X11=Yes where needed (can't we fully get rid of it?)
and set USE_X11=No where needed
agreed by aja@
   2010-10-11 02:19:21 by Jasper Lievisse Adriaanse | Files touched by this commit (77)
Log message:
- fix WANTLIB after cairo update.
   2010-10-01 11:20:46 by Antoine Jacoutot | Files touched by this commit (1)
Log message:
Unbreak -> WANTLIB.
   2010-09-27 06:13:26 by Antoine Jacoutot | Files touched by this commit (1)
Log message:
Fix DEPENDS.
   2010-08-30 15:53:59 by Stuart Henderson | Files touched by this commit (28)
Log message:
python bumps
   2010-07-25 03:07:01 by Antoine Jacoutot | Files touched by this commit (3)
Log message:
More typos.
   2010-07-25 02:15:33 by Antoine Jacoutot | Files touched by this commit (83)
Log message:
Switch to new DEPENDS/WANTLIB/REVISION.
   2010-07-19 08:55:03 by Landry Breuil | Files touched by this commit (4)
Log message:
Convert py-gnome-extras to build against/use xulrunner 1.9, patch mostly
taken from debian. Added comments to patches while here.
This needs a very -current xulrunner, hence version check enforced in
LIB/BUILD_DEPENDS.
ok ajacoutot@
   2010-07-19 08:55:03 by Landry Breuil | Files touched by this commit (4)
Log message:
Convert py-gnome-extras to build against/use xulrunner 1.9, patch mostly
taken from debian. Added comments to patches while here.
This needs a very -current xulrunner, hence version check enforced in
LIB/BUILD_DEPENDS.
ok ajacoutot@
   2010-07-19 08:55:03 by Landry Breuil | Files touched by this commit (4)
Log message:
Convert py-gnome-extras to build against/use xulrunner 1.9, patch mostly
taken from debian. Added comments to patches while here.
This needs a very -current xulrunner, hence version check enforced in
LIB/BUILD_DEPENDS.
ok ajacoutot@
   2010-07-19 08:55:03 by Landry Breuil | Files touched by this commit (4)
Log message:
Convert py-gnome-extras to build against/use xulrunner 1.9, patch mostly
taken from debian. Added comments to patches while here.
This needs a very -current xulrunner, hence version check enforced in
LIB/BUILD_DEPENDS.
ok ajacoutot@
   2010-07-13 14:37:04 by Antoine Jacoutot | Files touched by this commit (53)
Log message:
Use REVISION.
   2010-04-24 11:00:35 by Antoine Jacoutot | Files touched by this commit (23)
Log message:
WANTLIB.
   2010-04-21 01:36:59 by Jasper Lievisse Adriaanse | Files touched by this commit (2)
Log message:
- remove gtkhtml2 support, that project is dead and py-gnome-extras ought to
switch to gtkhtml3.
agreed by aja@
   2010-04-21 01:36:59 by Jasper Lievisse Adriaanse | Files touched by this commit (2)
Log message:
- remove gtkhtml2 support, that project is dead and py-gnome-extras ought to
switch to gtkhtml3.
agreed by aja@
   2010-04-04 04:50:21 by Stuart Henderson | Files touched by this commit (7)
Log message:
sync WANTLIB, bump PKGNAMEs. ok ajacoutot@
   2009-11-24 02:01:47 by Antoine Jacoutot | Files touched by this commit (10)
Log message:
Fix xulrunner package spec.
from an original diff for yelp by Mikolaj Kucharski
   2009-10-14 17:54:01 by Jasper Lievisse Adriaanse | Files touched by this commit (2)
Log message:
- re-enable gda bindings
   2009-10-14 17:54:01 by Jasper Lievisse Adriaanse | Files touched by this commit (2)
Log message:
- re-enable gda bindings
   2009-10-14 12:15:15 by Antoine Jacoutot | Files touched by this commit (2)
Log message:
Comment the gksu things we will never support.
ok jasper@
   2009-10-14 12:15:15 by Antoine Jacoutot | Files touched by this commit (2)
Log message:
Comment the gksu things we will never support.
ok jasper@
   2009-10-14 11:13:48 by Jasper Lievisse Adriaanse | Files touched by this commit (7)
Log message:
- update py-gnome-extras to 2.25.3
- unbreak after libgksu(ui) removal
* disables the gda bindings for now
   2009-10-14 11:13:48 by Jasper Lievisse Adriaanse | Files touched by this commit (7)
Log message:
- update py-gnome-extras to 2.25.3
- unbreak after libgksu(ui) removal
* disables the gda bindings for now
   2009-10-14 11:13:48 by Jasper Lievisse Adriaanse | Files touched by this commit (7)
Log message:
- update py-gnome-extras to 2.25.3
- unbreak after libgksu(ui) removal
* disables the gda bindings for now
   2009-10-14 11:13:48 by Jasper Lievisse Adriaanse | Files touched by this commit (7)
Log message:
- update py-gnome-extras to 2.25.3
- unbreak after libgksu(ui) removal
* disables the gda bindings for now
   2009-10-14 11:13:48 by Jasper Lievisse Adriaanse | Files touched by this commit (7)
Log message:
- update py-gnome-extras to 2.25.3
- unbreak after libgksu(ui) removal
* disables the gda bindings for now
   2009-10-14 11:13:48 by Jasper Lievisse Adriaanse | Files touched by this commit (7)
Log message:
- update py-gnome-extras to 2.25.3
- unbreak after libgksu(ui) removal
* disables the gda bindings for now
   2009-10-14 11:13:48 by Jasper Lievisse Adriaanse | Files touched by this commit (7)
Log message:
- update py-gnome-extras to 2.25.3
- unbreak after libgksu(ui) removal
* disables the gda bindings for now
   2009-08-11 02:39:39 by Antoine Jacoutot | Files touched by this commit (81)
Log message:
WANTLIB changes after xcb addition and bump.
   2009-07-27 15:44:15 by Martynas Venckus | Files touched by this commit (14)
Log message:
adapt for the new xulrunner infrastructure.
no breakage in bulk build & bumps done by sthen@
   2009-06-24 18:38:38 by Stuart Henderson | Files touched by this commit (9)
Log message:
sync wantlib, bump
   2009-04-26 05:01:05 by Antoine Jacoutot | Files touched by this commit (57)
Log message:
CONFIGURE_ENV += PYTHON="${MODPY_BIN}" is inherited from the python module
   2009-03-28 10:32:19 by Christian Weisgerber | Files touched by this commit (2)
Log message:
bump for python dependency change
   2009-02-11 08:47:52 by Jasper Lievisse Adriaanse | Files touched by this commit (99)
Log message:
- bah...missing '>' :(
   2009-02-11 08:33:53 by Jasper Lievisse Adriaanse | Files touched by this commit (99)
Log message:
- add another tadpole as maintainer of this hobbit
   2009-02-11 08:22:02 by Antoine Jacoutot | Files touched by this commit (1)
Log message:
- fix WANTLIB after libgda change
"go for it!" jasper@
   2009-01-20 16:13:31 by Antoine Jacoutot | Files touched by this commit (41)
Log message:
- regen WANTLIB after libgnome esound support removal
   2008-11-22 17:10:57 by Antoine Jacoutot | Files touched by this commit (1)
Log message:
- forgot one build+run_depends in previous commit
   2008-11-22 16:55:08 by Antoine Jacoutot | Files touched by this commit (4)
Log message:
- add some missing lib_depends
- fix build with latest gdl (from upstream SVN via jasper@)
- sync DESCR with reality
   2008-11-22 16:55:08 by Antoine Jacoutot | Files touched by this commit (4)
Log message:
- add some missing lib_depends
- fix build with latest gdl (from upstream SVN via jasper@)
- sync DESCR with reality
   2008-11-22 16:55:08 by Antoine Jacoutot | Files touched by this commit (4)
Log message:
- add some missing lib_depends
- fix build with latest gdl (from upstream SVN via jasper@)
- sync DESCR with reality
   2008-11-22 16:55:08 by Antoine Jacoutot | Files touched by this commit (4)
Log message:
- add some missing lib_depends
- fix build with latest gdl (from upstream SVN via jasper@)
- sync DESCR with reality
   2008-08-26 12:11:03 by Martynas Venckus | Files touched by this commit (2)
Log message:
- use a proper way to mark RPATH (-R backwards-compat flag didn't
mark resulting libmozembed here)
- workaround no more
ok kurt@
   2008-08-26 12:11:03 by Martynas Venckus | Files touched by this commit (2)
Log message:
- use a proper way to mark RPATH (-R backwards-compat flag didn't
mark resulting libmozembed here)
- workaround no more
ok kurt@
   2008-08-23 15:40:08 by Martynas Venckus | Files touched by this commit (1)
Log message:
give regression tests a chance to work.  no package changes
ok wcmaier@
   2008-06-02 08:10:07 by Antoine Jacoutot | Files touched by this commit (34)
Log message:
- remove support for MODGNOME_DEVHELP_FILES from the gnome MODULE ;
it makes more sense to add devhelp as run_depends for gnome-session and
leave it to the user to install it manually for other packages
"if you're as happy as a pig in poop, commit it" jasper@