./x11/grantlee [template and text document library for Qt4]
[+] Add this package to your ports tracker

[ CVSweb ] [ Homepage ] [ RSS feed ]

Version: 0.5.1, Package name: grantlee-0.5.1
Maintained by: KDE porting team
Master sites:
Description
Grantlee is a theming framework for Qt applications.


Filesize: 1145.282 KB
Version History (View Complete History)
  • (2015-08-16) Updated to version: grantlee-0.5.1
  • (2015-07-02) Updated to version: grantlee-0.5.0
  • (2013-03-26) Package added to openports.se, version grantlee-0.3.0 (created)
[show/hide] View available PLISTS (Can be a lot of data)

CVS Commit History:

   2017-07-26 16:45:35 by Stuart Henderson | Files touched by this commit (937)
Log message:
bump LIBCXX/LIBECXX/COMPILER_LIBCXX ports.
   2017-07-23 03:26:30 by Marc Espie | Files touched by this commit (244)
Log message:
add pthread to COMPILER_LIBCXX.
white lie, but it allows clang and gcc to be more similar
bump accordingly.
   2017-07-16 13:19:06 by Marc Espie | Files touched by this commit (880)
Log message:
use COMPILER_LIBCXX where applicable
   2017-04-10 05:46:37 by Stuart Henderson | Files touched by this commit (277)
Log message:
use LIBCXX
   2016-03-18 17:12:22 by Christian Weisgerber | Files touched by this commit (183)
Log message:
remove SHARED_ONLY from ports that only use modules that neither set nor
read this variable
   2016-02-29 21:28:58 by Michael McConville | Files touched by this commit (1)
Log message:
update HOMEPAGE, crank REVISION
ok juanfra@
   2015-08-15 16:30:57 by Vadim Zhukov | Files touched by this commit (2)
Log message:
Small maintaince update to 0.5.1, fixing a possible crash.
This is the last Qt4 release, all further versions are Qt5-based, so
we'll have a separate grantlee-qt5 port at some time in the near future.
   2015-08-15 16:30:57 by Vadim Zhukov | Files touched by this commit (2)
Log message:
Small maintaince update to 0.5.1, fixing a possible crash.
This is the last Qt4 release, all further versions are Qt5-based, so
we'll have a separate grantlee-qt5 port at some time in the near future.
   2015-08-13 16:35:15 by Vadim Zhukov | Files touched by this commit (1)
Log message:
Stop hiding: nobody uses Grantlee outside KDE, so take maintainership.
Also, teach portroach to ignore 5.x versions, as those are Qt5-based,
which is obvious no-no for KDE4.
   2015-07-01 18:10:16 by Vadim Zhukov | Files touched by this commit (30)
Log message:
Maintaince update of some KDE4 components, brought to you (mostly) by
KDE PIM team.
Includes update of Grantlee to 0.5.0, last KDE4 release; previous version,
0.3.0, was too old for new kdepim. Separate update will be problematic
because PLIST of kdepim package relies on minor version of Grantlee.
Lightly tested on amd64.
   2015-07-01 18:10:16 by Vadim Zhukov | Files touched by this commit (30)
Log message:
Maintaince update of some KDE4 components, brought to you (mostly) by
KDE PIM team.
Includes update of Grantlee to 0.5.0, last KDE4 release; previous version,
0.3.0, was too old for new kdepim. Separate update will be problematic
because PLIST of kdepim package relies on minor version of Grantlee.
Lightly tested on amd64.
   2015-07-01 18:10:16 by Vadim Zhukov | Files touched by this commit (30)
Log message:
Maintaince update of some KDE4 components, brought to you (mostly) by
KDE PIM team.
Includes update of Grantlee to 0.5.0, last KDE4 release; previous version,
0.3.0, was too old for new kdepim. Separate update will be problematic
because PLIST of kdepim package relies on minor version of Grantlee.
Lightly tested on amd64.
   2015-07-01 18:10:16 by Vadim Zhukov | Files touched by this commit (30)
Log message:
Maintaince update of some KDE4 components, brought to you (mostly) by
KDE PIM team.
Includes update of Grantlee to 0.5.0, last KDE4 release; previous version,
0.3.0, was too old for new kdepim. Separate update will be problematic
because PLIST of kdepim package relies on minor version of Grantlee.
Lightly tested on amd64.
   2015-07-01 18:10:16 by Vadim Zhukov | Files touched by this commit (30)
Log message:
Maintaince update of some KDE4 components, brought to you (mostly) by
KDE PIM team.
Includes update of Grantlee to 0.5.0, last KDE4 release; previous version,
0.3.0, was too old for new kdepim. Separate update will be problematic
because PLIST of kdepim package relies on minor version of Grantlee.
Lightly tested on amd64.
   2015-07-01 18:10:16 by Vadim Zhukov | Files touched by this commit (30)
Log message:
Maintaince update of some KDE4 components, brought to you (mostly) by
KDE PIM team.
Includes update of Grantlee to 0.5.0, last KDE4 release; previous version,
0.3.0, was too old for new kdepim. Separate update will be problematic
because PLIST of kdepim package relies on minor version of Grantlee.
Lightly tested on amd64.
   2015-07-01 18:10:16 by Vadim Zhukov | Files touched by this commit (30)
Log message:
Maintaince update of some KDE4 components, brought to you (mostly) by
KDE PIM team.
Includes update of Grantlee to 0.5.0, last KDE4 release; previous version,
0.3.0, was too old for new kdepim. Separate update will be problematic
because PLIST of kdepim package relies on minor version of Grantlee.
Lightly tested on amd64.
   2015-07-01 18:10:16 by Vadim Zhukov | Files touched by this commit (30)
Log message:
Maintaince update of some KDE4 components, brought to you (mostly) by
KDE PIM team.
Includes update of Grantlee to 0.5.0, last KDE4 release; previous version,
0.3.0, was too old for new kdepim. Separate update will be problematic
because PLIST of kdepim package relies on minor version of Grantlee.
Lightly tested on amd64.
   2015-07-01 18:10:16 by Vadim Zhukov | Files touched by this commit (30)
Log message:
Maintaince update of some KDE4 components, brought to you (mostly) by
KDE PIM team.
Includes update of Grantlee to 0.5.0, last KDE4 release; previous version,
0.3.0, was too old for new kdepim. Separate update will be problematic
because PLIST of kdepim package relies on minor version of Grantlee.
Lightly tested on amd64.
   2014-11-07 03:05:29 by Landry Breuil | Files touched by this commit (18)
Log message:
Use MODCMAKE_BUILD_SUFFIX where appropriate, bump REVISION when the PLIST
actually changes.
   2014-11-07 03:05:29 by Landry Breuil | Files touched by this commit (18)
Log message:
Use MODCMAKE_BUILD_SUFFIX where appropriate, bump REVISION when the PLIST
actually changes.