./databases/barman [backup and restoration manager for PostgreSQL]
[+] Add this package to your ports tracker

[ CVSweb ] [ Homepage ] [ RSS feed ]

Version: 2.17, Package name: barman-2.17
Maintained by: The OpenBSD ports mailing-list
Master sites:
Description
Barman (backup and recovery manager) is an administration tool for
disaster recovery of PostgreSQL servers written in Python. Barman can
perform remote backups of multiple servers in business critical
environments, and helps DBAs during the recovery phase.

Barman's most wanted features include: backup catalogues, retention
policies, remote recovery, archiving and compression of WAL files and
of backups.


Filesize: 1359.981 KB
Version History (View Complete History)
  • (2021-12-02) Updated to version: barman-2.17
  • (2021-11-21) Updated to version: barman-2.15
  • (2021-02-20) Updated to version: barman-2.12
  • (2017-11-06) Updated to version: barman-2.3
  • (2017-08-20) Updated to version: barman-2.2
  • (2016-05-14) Updated to version: barman-1.6.0
  • (2015-12-23) Updated to version: barman-1.5.1
  • (2015-05-14) Updated to version: barman-1.4.1
  • (2015-03-25) Updated to version: barman-1.4.0
  • (2013-08-10) Package added to openports.se, version barman-1.2.2 (created)
[show/hide] View available PLISTS (Can be a lot of data)

CVS Commit History:

   2021-11-21 03:05:24 by Stuart Henderson | Files touched by this commit (4)
Log message:
update to barman-2.15
   2021-11-01 18:00:17 by Stuart Henderson | Files touched by this commit (85)
Log message:
bump REVISION for switch from Python 3.8 -> 3.9
   2021-02-23 12:39:53 by Stuart Henderson | Files touched by this commit (743)
Log message:
Reverse the polarity of MODPY_VERSION; default is now 3.x,
if a port needs 2.x then set MODPY_VERSION=${MODPY_DEFAULT_VERSION_2}.
This commit doesn't change any versions currently used; it may be that
some ports have MODPY_DEFAULT_VERSION_2 but don't require it, those
should be cleaned up in the course of updating ports where possible.
Python module ports providing py3-* packages should still use
FLAVOR=python3 so that we don't have a mixture of dependencies some
using ${MODPY_FLAVOR} and others not.
   2021-02-20 03:22:22 by Stuart Henderson | Files touched by this commit (1)
Log message:
missed cvs rm
   2021-02-19 18:58:10 by Stuart Henderson | Files touched by this commit (4)
Log message:
update to barman-2.12, switch to py3
   2019-07-12 14:44:13 by Stuart Henderson | Files touched by this commit (877)
Log message:
replace simple PERMIT_PACKAGE_CDROM=Yes with PERMIT_PACKAGE=Yes
   2019-05-15 06:04:43 by Kurt Mosiejczuk | Files touched by this commit (167)
Log message:
Add RUN_DEPENDS to TEST_DEPENDS automatically for ports using the
lang/python port module. I've not yet come up with a port that
would not need this and one can always set MODPY_TESTDEP to "no"
to prevent the module from touching TEST_DEPENDS.
Idea from afresh1 who pointed out the cpan module already does this.
aja "I support this move."
OK sthen@
   2018-09-04 06:46:28 by Marc Espie | Files touched by this commit (918)
Log message:
convert to PKGSTEM
   2017-08-20 08:25:33 by Jasper Lievisse Adriaanse | Files touched by this commit (7)
Log message:
update to barman-2.2
   2017-03-17 01:15:01 by Antoine Jacoutot | Files touched by this commit (5)
Log message:
Drop MAINTAINER per his request.
   2016-12-09 11:57:40 by Jasper Lievisse Adriaanse | Files touched by this commit (3)
Log message:
regen and add RCS id
   2016-05-13 12:05:01 by Landry Breuil | Files touched by this commit (4)
Log message:
Update to barman 1.6.0, from MAINTAINER Eric Lalonde.
Added some commented out/unimported yet test dependencies
   2015-12-22 14:36:31 by Landry Breuil | Files touched by this commit (4)
Log message:
Update to barman 1.5.1, from MAINTAINER Eric Lalonde
With feedback from ajacoutot@
   2015-09-29 04:51:15 by Stuart Henderson | Files touched by this commit (30)
Log message:
bump REVISION for setuptools dep change.
   2015-05-13 14:11:42 by Jeremie Courreges-Anglas | Files touched by this commit (1)
Log message:
Regen patch.
   2015-05-13 14:11:24 by Jeremie Courreges-Anglas | Files touched by this commit (2)
Log message:
Bugfix update to barman-1.4.1, from maintainer Eric Lalonde
   2015-03-24 14:25:01 by Landry Breuil | Files touched by this commit (4)
Log message:
Update to barman 1.4.0, from Eric Lalonde who takes maintainership.
See http://www.postgresql.org/about/news/1566/ for details.
While here add NO_TEST=Yes since tests depends on pytest libs not ported
yet.