./devel/cabal-install [command-line interface for Cabal and Hackage]
[+] Add this package to your ports tracker

[ CVSweb ] [ Homepage ] [ RSS feed ]

Version: 3.6.3.0, Package name: cabal-install-3.6.3.0
Maintained by: Matthias Kilian
Master sites:
Description
The 'cabal' command-line program simplifies the process of managing
Haskell software by automating the fetching, configuration, compilation
and installation of Haskell libraries and programs.


Filesize: 5.204 KB
Version History (View Complete History)
  • (2022-04-30) Updated to version: cabal-install-3.6.3.0
  • (2021-12-11) Updated to version: cabal-install-3.6.2.0
  • (2021-02-23) Updated to version: cabal-install-3.4.0.0
  • (2019-09-30) Updated to version: cabal-install-2.4.0.0
  • (2018-01-23) Updated to version: cabal-install-2.0.0.1
  • (2017-11-08) Updated to version: cabal-install-1.24.0.0
  • (2015-09-19) Updated to version: cabal-install-1.22.6.0
  • (2014-11-23) Updated to version: cabal-install-1.18.0.5
  • (2013-07-19) Updated to version: cabal-install-1.16.0.2
  • (2012-09-03) Updated to version: cabal-install-0.14.0
[show/hide] View available PLISTS (Can be a lot of data)

CVS Commit History:

   2021-11-01 18:00:27 by Stuart Henderson | Files touched by this commit (99)
Log message:
bump REVISION for switch from Python 3.8 -> 3.9
   2021-06-08 22:22:20 by Greg Steuck | Files touched by this commit (11)
Log message:
Update lang/ghc to 8.10.5
The change in cabal-install has to be synchronized due to some
internal version numbers embedded into the JSON file.
ok kili@
   2021-03-15 16:08:14 by Matthias Kilian | Files touched by this commit (1)
Log message:
Add rdep on lang/ghc.
ok gnezdo@, kn@
   2021-03-09 18:33:55 by Greg Steuck | Files touched by this commit (4)
Log message:
Upgrade cabal-install to ghc-8.10
ok kili
   2021-02-23 12:39:53 by Stuart Henderson | Files touched by this commit (743)
Log message:
Reverse the polarity of MODPY_VERSION; default is now 3.x,
if a port needs 2.x then set MODPY_VERSION=${MODPY_DEFAULT_VERSION_2}.
This commit doesn't change any versions currently used; it may be that
some ports have MODPY_DEFAULT_VERSION_2 but don't require it, those
should be cleaned up in the course of updating ports where possible.
Python module ports providing py3-* packages should still use
FLAVOR=python3 so that we don't have a mixture of dependencies some
using ${MODPY_FLAVOR} and others not.
   2021-02-22 19:03:23 by Greg Steuck | Files touched by this commit (3)
Log message:
Upgrade cabal-install to 3.4.0.0
Uses a bootstrap.py developed upstream to limit Haskell dependencies
to just lang/ghc. This will allow cabal-install to be at the base of
cabal-based Haskell ports framework.
Looks fine by kili@
   2019-09-30 05:53:37 by Matthias Kilian | Files touched by this commit (2)
Log message:
Update to cabal-install-2.4.0.0.
Joint work with Greg Steuck.
   2019-07-12 14:44:13 by Stuart Henderson | Files touched by this commit (877)
Log message:
replace simple PERMIT_PACKAGE_CDROM=Yes with PERMIT_PACKAGE=Yes
   2018-01-22 14:54:16 by Matthias Kilian | Files touched by this commit (2)
Log message:
Update to cabal-install-2.0.0.1.
   2016-09-13 08:40:30 by Christian Weisgerber | Files touched by this commit (20)
Log message:
replace libiconv module
   2016-01-29 13:28:09 by Matthias Kilian | Files touched by this commit (46)
Log message:
Let portroach ignore ports on which meta/haskell-platform depends.
Except lang/ghc for now (in case someone doesn't like my diff on ports@).
   2015-09-19 01:50:06 by Matthias Kilian | Files touched by this commit (2)
Log message:
Update to cabal-install-1.22.6.0.
   2014-11-22 13:31:30 by Matthias Kilian | Files touched by this commit (2)
Log message:
Update to cabal-install-1.18.0.5.
   2011-06-30 15:30:20 by Matthias Kilian | Files touched by this commit (10)
Log message:
Bump after ghc update.
   2011-04-23 14:22:13 by Matthias Kilian | Files touched by this commit (11)
Log message:
New distinfo after DIST_SUBDIR change in ghc.port.mk.
   2011-04-11 08:36:45 by Matthias Kilian | Files touched by this commit (2)
Log message:
Update to 0.10.2.
   2010-11-15 12:46:10 by Marc Espie | Files touched by this commit (706)
Log message:
move depends to new style
   2010-09-12 05:47:14 by Matthias Kilian | Files touched by this commit (2)
Log message:
Update to cabal-install-0.8.2.
Remove VMEM_WARNING, the port build fine with default limits.
   2010-07-17 07:54:30 by Matthias Kilian | Files touched by this commit (12)
Log message:
Switch to REVISION and new WANTLIB/LIB_DEPENDS style.
   2010-06-30 09:41:02 by Matthias Kilian | Files touched by this commit (17)
Log message:
WANTLIB += pthread and bump PKGNAME.
   2010-06-15 11:59:24 by Matthias Kilian | Files touched by this commit (12)
Log message:
Add gmp and bump.
   2010-05-06 14:05:24 by Matthias Kilian | Files touched by this commit (12)
Log message:
Adjust WANTLIB and bump PKGNAME after the ghc change.