NOTICE: This package no longer exists in Ports

BROKEN: will be removed soon


./devel/hs-hashed-storage [hashed file storage support code for Haskell]

[ CVSweb ] [ Homepage ] [ RSS feed ]

Version: 0.5.11, Package name: hs-hashed-storage-0.5.11
Maintained by: Matthias Kilian
Master sites:
Description
Support code for reading and manipulating hashed file storage (where
each file and directory is associated with a cryptographic hash,
for corruption-resistant storage and fast comparisons).

The supported storage formats include darcs hashed pristine, a plain
filesystem tree and an indexed plain tree (where the index maintains
hashes of the plain files and directories).


Filesize: 55.972 KB
Version History (View Complete History)
  • (2015-12-24) Package deleted from Ports
  • (2014-11-24) Updated to version: hs-hashed-storage-0.5.11
  • (2013-07-19) Updated to version: hs-hashed-storage-0.5.10
  • (2012-04-26) Updated to version: hs-hashed-storage-0.5.9
  • (2011-04-13) Updated to version: hs-hashed-storage-0.5.4
  • (2010-11-03) Updated to version: hs-hashed-storage-0.5.2
  • (2010-06-25) Updated to version: hs-hashed-storage-0.4.13p3
  • (2010-06-06) Updated to version: hs-hashed-storage-0.4.13p2
  • (2010-05-19) Updated to version: hs-hashed-storage-0.4.13p1
  • (2010-05-14) Updated to version: hs-hashed-storage-0.4.13p0
[show/hide] View available PLISTS (Can be a lot of data)

CVS Commit History:

   2015-12-23 13:15:08 by Matthias Kilian | Files touched by this commit (4)
Log message:
Remove devel/hs-hashed-storage. It's no longer useful.
   2015-10-12 15:38:47 by Matthias Kilian | Files touched by this commit (1)
Log message:
Explicitely mark as broken to remove dpb clutter.
This will be removed after an uodate of devel/darcs.
   2014-11-24 09:07:59 by Matthias Kilian | Files touched by this commit (37)
Log message:
Update plists and bump.
   2011-04-23 14:23:15 by Matthias Kilian | Files touched by this commit (11)
Log message:
New distinfo after DIST_SUBDIR change in ghc.port.mk.
   2011-04-23 08:32:51 by Matthias Kilian | Files touched by this commit (43)
Log message:
Depend on and use mtl-2 from devel/hs-mtl.
   2011-04-11 08:40:00 by Matthias Kilian | Files touched by this commit (3)
Log message:
Update to 0.5.4.
   2010-11-15 12:46:10 by Marc Espie | Files touched by this commit (706)
Log message:
move depends to new style
   2010-11-03 16:13:39 by Matthias Kilian | Files touched by this commit (57)
Log message:
bumpski
   2010-11-02 14:21:40 by Matthias Kilian | Files touched by this commit (2)
Log message:
Update to hashed-storage-0.5.2
   2010-10-28 07:51:48 by Jasper Lievisse Adriaanse | Files touched by this commit (110)
Log message:
- regen plist after recent ghc.port.mk change
- adjust @exec/@unexec accordingly
"just go ahead" kili@
   2010-07-17 07:43:37 by Matthias Kilian | Files touched by this commit (25)
Log message:
Add LIB_DEPENDS to RUN_DEPENDS.
Switch to REVISION.
Bump.
   2010-06-15 11:18:51 by Matthias Kilian | Files touched by this commit (33)
Log message:
Bump after ghc update.
   2010-06-06 04:06:45 by Matthias Kilian | Files touched by this commit (38)
Log message:
Bump after the stupid ABI changes in GHC.
   2010-05-19 09:58:23 by Matthias Kilian | Files touched by this commit (76)
Log message:
Silent register.sh/unregister.sh after the change to Cabal in ghc.
Run unregister.sh with `--force'.
   2010-05-14 03:08:27 by Matthias Kilian | Files touched by this commit (70)
Log message:
Use @unexec. I must have been on drugs when using @unexec-delete
for unregister.sh in all the new ghc libraries (which leads to bogus
registered ghc packages after updates).
You can use the command
ghc-pkg check
to check ghcs internal package list. If it reports missing files
for some package (like hashed-storage-0.4.11), you can forcibly
unregister it by running (as root) something like
ghc-pkg unregister hashed-storage-0.4.11
ok dcoppa@
   2010-05-09 11:00:00 by Matthias Kilian | Files touched by this commit (2)
Log message:
Update to hs-hashed-storage-0.4.13.
   2010-04-13 06:28:37 by Matthias Kilian | Files touched by this commit (2)
Log message:
New darcs will need exactly hs-hashed-storage-0.4.11.