./devel/libftdi1 [libftdi, interface to ftdi debug device]
[+] Add this package to your ports tracker

[ CVSweb ] [ Homepage ] [ RSS feed ]

Version: 1.5, Package name: libftdi1-1.5
Maintained by: The OpenBSD ports mailing-list
Master sites:
Description
libFTDI is an open source library to talk to FTDI chips: FT232BM, FT245BM,
FT2232C, FT2232D, FT245R, FT232H and FT230X including the popular bitbang
mode. The library is linked with programs in userspace, no kernel driver
required.


Filesize: 113.571 KB
Version History (View Complete History)
  • (2021-03-15) Updated to version: libftdi1-1.5
  • (2018-11-03) Package added to openports.se, version libftdi1-1.4 (created)
[show/hide] View available PLISTS (Can be a lot of data)

CVS Commit History:

   2021-03-14 15:48:58 by Stuart Henderson | Files touched by this commit (3)
Log message:
update to libftdi1-1.5
   2021-02-23 12:39:53 by Stuart Henderson | Files touched by this commit (743)
Log message:
Reverse the polarity of MODPY_VERSION; default is now 3.x,
if a port needs 2.x then set MODPY_VERSION=${MODPY_DEFAULT_VERSION_2}.
This commit doesn't change any versions currently used; it may be that
some ports have MODPY_DEFAULT_VERSION_2 but don't require it, those
should be cleaned up in the course of updating ports where possible.
Python module ports providing py3-* packages should still use
FLAVOR=python3 so that we don't have a mixture of dependencies some
using ${MODPY_FLAVOR} and others not.
   2021-01-04 07:06:39 by Stuart Henderson | Files touched by this commit (242)
Log message:
regen PLISTs for python ports with .so files that end up renamed due to
the EXT_SUFFIX change in Python 3.8.7
   2020-07-03 15:13:23 by Stuart Henderson | Files touched by this commit (1032)
Log message:
bump REVISION; python 3 default changed to 3.8
   2019-09-30 00:35:00 by Rafael Sadowski | Files touched by this commit (1)
Log message:
Unbreak build after doxygen update
We disable the use of doxygen in all ports. It was forgotten here.
   2019-07-12 14:45:17 by Stuart Henderson | Files touched by this commit (859)
Log message:
replace simple PERMIT_PACKAGE_CDROM=Yes with PERMIT_PACKAGE=Yes
   2019-05-20 16:15:31 by Christian Weisgerber | Files touched by this commit (488)
Log message:
Update gettext to 0.20.1.
Follow the upstream recommendations for packagers and switch to
multi-packages:
devel/gettext       -> devel/gettext,-runtime
devel/gettext-tools -> devel/gettext,-tools
(new)                  devel/gettext,-textstyle
   2019-04-28 14:52:03 by Stuart Henderson | Files touched by this commit (715)
Log message:
bump all the py3 things, _SYSTEM_VERSION didn't quite work out how
we expected and it's easier|safer to do it this way than fiddle with
pkg_add now. thanks aja for update tests with a quick bulk.