./devel/py-selectors2 [backported, durable, and portable selectors]
[+] Add this package to your ports tracker

[ CVSweb ] [ Homepage ] [ RSS feed ]

Version: 2.0.2, Package name: py-selectors2-2.0.2
Maintained by: The OpenBSD ports mailing-list
Master sites:
Description
Backported, durable, and portable selectors designed to replace the
standard library selectors module.


Filesize: 18.123 KB
Version History (View Complete History)
  • (2020-11-21) Updated to version: py-selectors2-2.0.2
  • (2019-05-10) Package added to openports.se, version py-selectors2-2.0.1 (created)
[show/hide] View available PLISTS (Can be a lot of data)

CVS Commit History:

   2021-02-23 12:39:53 by Stuart Henderson | Files touched by this commit (743)
Log message:
Reverse the polarity of MODPY_VERSION; default is now 3.x,
if a port needs 2.x then set MODPY_VERSION=${MODPY_DEFAULT_VERSION_2}.
This commit doesn't change any versions currently used; it may be that
some ports have MODPY_DEFAULT_VERSION_2 but don't require it, those
should be cleaned up in the course of updating ports where possible.
Python module ports providing py3-* packages should still use
FLAVOR=python3 so that we don't have a mixture of dependencies some
using ${MODPY_FLAVOR} and others not.
   2020-11-21 08:39:51 by Benoit Lecocq | Files touched by this commit (2)
Log message:
Update to py-selectors2-2.0.2.
   2019-07-12 14:46:30 by Stuart Henderson | Files touched by this commit (853)
Log message:
replace simple PERMIT_PACKAGE_CDROM=Yes with PERMIT_PACKAGE=Yes