./devel/py-subprocess32 [backport of the subprocess library module from Python 3]
[+] Add this package to your ports tracker

[ CVSweb ] [ Homepage ] [ RSS feed ]

Version: 3.5.2, Package name: py-subprocess32-3.5.2
Maintained by: The OpenBSD ports mailing-list
Master sites:
Description
This is a backport of the subprocess standard library module from
Python 3.2 - 3.5 for use on Python 2.

It includes bugfixes and some new features. On POSIX systems it is
guaranteed to be reliable when used in threaded applications. It
includes timeout support from Python 3.3 and the run() API from 3.5
but otherwise matches 3.2's API.


Filesize: 94.485 KB
Version History (View Complete History)
  • (2018-10-18) Package added to openports.se, version py-subprocess32-3.5.2 (created)
[show/hide] View available PLISTS (Can be a lot of data)

CVS Commit History:

   2021-05-21 13:50:39 by Kurt Mosiejczuk | Files touched by this commit (326)
Log message:
Bump the REVISION on all ports that use the python2 version of
py-setuptools.
Also change the lang/python module to use the new
devel/py2-setuptools for python2 ports
ok sthen@
   2021-02-23 12:39:53 by Stuart Henderson | Files touched by this commit (743)
Log message:
Reverse the polarity of MODPY_VERSION; default is now 3.x,
if a port needs 2.x then set MODPY_VERSION=${MODPY_DEFAULT_VERSION_2}.
This commit doesn't change any versions currently used; it may be that
some ports have MODPY_DEFAULT_VERSION_2 but don't require it, those
should be cleaned up in the course of updating ports where possible.
Python module ports providing py3-* packages should still use
FLAVOR=python3 so that we don't have a mixture of dependencies some
using ${MODPY_FLAVOR} and others not.
   2019-11-19 18:17:06 by Kurt Mosiejczuk | Files touched by this commit (1)
Log message:
Move testing to MODPY_PYTEST
   2019-07-12 14:46:30 by Stuart Henderson | Files touched by this commit (853)
Log message:
replace simple PERMIT_PACKAGE_CDROM=Yes with PERMIT_PACKAGE=Yes