./devel/ruby-shims [Ruby version redirection shim]
[+] Add this package to your ports tracker

[ CVSweb ] [ Homepage ] [ RSS feed ]

Version: 3, Package name: ruby-shims-3
Maintained by: joshua stein
Description
ruby-shims is a set of symlinks to a script that executes Ruby binaries
based on a per-directory .ruby-version or system-wide /etc/ruby-version
file.

The file must only contain the exact version string, e.g.

$ cat .ruby-version
2.6
$ ruby --version
ruby 2.6.5p114 (2019-10-01 revision 67812) [sparc64-openbsd]


Version History (View Complete History)
  • (2020-04-24) Updated to version: ruby-shims-3
  • (2020-01-13) Package added to openports.se, version ruby-shims-2 (created)
[show/hide] View available PLISTS (Can be a lot of data)

CVS Commit History:

   2020-05-14 15:08:01 by joshua stein | Files touched by this commit (3)
Log message:
update maintainer email address
   2020-04-23 13:00:17 by Klemens Nanni | Files touched by this commit (3)
Log message:
Provide version example, move shim script out of PATH
Without documentation and/or prior Ruby experience, it is not obvious
what /etc/ruby-version should contain.
The shim script itself should not be called directly, move it to
libexec/rubyshim to make this clearer.
   2020-04-19 16:31:30 by Klemens Nanni | Files touched by this commit (4)
Log message:
Register conflict on bundle executable
Both install /usr/local/bin/bundle.