./math/py-oldest-supported-numpy [pypi meta-package to depend on numpy]
[+] Add this package to your ports tracker

[ CVSweb ] [ Homepage ] [ RSS feed ]

Version: 2022.8.16, Package name: py-oldest-supported-numpy-2022.8.16
Maintained by: The OpenBSD ports mailing-list
Master sites:
Flavors (export FLAVOR=xyz, setenv FLAVOR xyz):
  • python3
Description
This is a Python meta-package which can be used in pyproject.toml files
to automatically provide as a build-time dependency on Numpy.

Normally it is used to depend on the oldest version that supports the
given Python version and platform where a pre-built Numpy wheel is
available, such that compiled extensions are ABI-compatible with a
wider range of Numpy versions.

For OpenBSD packages where we manage dependencies internally and
don't use upstream pre-built wheels, this is modified to allow any
version.


Filesize: 3.818 KB
Version History (View Complete History)
  • (2022-09-12) Package added to openports.se, version py-oldest-supported-numpy-2022.8.16 (created)
[show/hide] View available PLISTS (Can be a lot of data)