./x11/kde-applications/khelpcenter [KDE help center]
[+] Add this package to your ports tracker

[ CVSweb ] [ Homepage ] [ RSS feed ]

Version: 19.12.3, Package name: khelpcenter-19.12.3
Maintained by: Rafael Sadowski
Master sites:
Description
KHelpCenter - Help Center and documentation viewer

Features
- Show documentation from various sources
- Fundamentals and Plasma Manual
- Application manuals
- Systemsettings modules
- Kioslaves
- KInfoCenter Modules
- Man pages
- Info pages
- Glossary
- Search through the available documentation


Filesize: 3755.469 KB
Version History (View Complete History)
  • (2020-03-24) Updated to version: khelpcenter-19.12.3
  • (2018-12-18) Updated to version: khelpcenter-18.12.0
  • (2018-12-09) Package added to openports.se, version khelpcenter-18.08.2 (created)
[show/hide] View available PLISTS (Can be a lot of data)

CVS Commit History:

   2020-06-04 23:40:30 by Rafael Sadowski | Files touched by this commit (122)
Log message:
Use MODKF5_I18N_CONFLICT=yes instead of @conflict kde-i18n-*
   2020-06-02 23:13:46 by Rafael Sadowski | Files touched by this commit (222)
Log message:
Use MODKF5_L10N_CONFLICT=yes instead of @conflict kde-l10n-*
   2020-03-23 12:01:30 by Rafael Sadowski | Files touched by this commit (700)
Log message:
Update KDE Frameworks to 5.68.0 and KDE5 to 19.12
This commit includes 218 port updates and 16 tweak updates after KDE framework
changes. Most of this 16 changes caused by:
- KF5Auth split into KF5Auth and KF5AuthCore, which ends in a lot of new
WANTLIBs
- Upstream changed some xdg paths from share/examples/***/xdg/ to
share/qlogging-categories5/, which ends in a lot of PLIST chages.
List of notable changes:
- Bump all kf5 shared libs.
- Use ">=${MODKF5_VERSION}" in all kf5 ports that all kf5 use the
latest version an update together. (Idea from Qt5).
- s/=+/=/ for LIB_*,RUN_* and BUILD_* in x11/kde-applications, hint by jca@.
- Update okteta to 0.26.3
- Update spectacle only to 19.04.3, latest version without hard wayland
dependency.
- Remove python2 support in cantor, python3 only!
- devel/kf5/kfilemetadata: switch to python 3 (TDEP only), by kn@
- devel/kf5/ki18n: switch to python 3, by kn@
- devel/kf5/kservice: switch to python 3, by kn@
- devel/kf5/kconfigwidgets: remove python module usage, by kn@
- devel/kf5/ktextigwidgets: remove python module usage, by kn@
Tweaks and feedback from landry@, amd64 bulk build and error reports by naddy@
Thanks a lot!
   2019-03-24 05:57:04 by Rafael Sadowski | Files touched by this commit (106)
Log message:
Zap variable KDE5
We are now KDE4 free in kde-applications so there is no reason to tag KDE5
ports.
   2019-03-08 13:00:57 by Charlene Wendling | Files touched by this commit (344)
Log message:
qt5.port.mk: change COMPILER
Move it to "base-clang ports-gcc" and bump REVISION accordingly.
This unbreaks Qt5-related binaries runtime on macppc.
OK sthen@
   2018-12-18 02:39:21 by Rafael Sadowski | Files touched by this commit (246)
Log message:
Update KDE Applications to 18.12
Release notes:
https://www.kde.org/announcements/announce-applications-18.12.0.php
Port notes:
- Update all KDE5 ports to 18.12.0
- Reorder Makefile and enable libkmahjongg and kmahjongg
- Change MAINTAINER email
- New kde-applications.port.mk baesed on Makefile.inc
- Includes the following new helpers:
- MODKDE5_DESKTOP_FILE
- MODKDE5_ICON_CACHE
- MODKDE5_TRANSLATIONS
- MODKDE5_DOCS
- Makefile.inc improvements
- Fix and improve some many @pkgpath's, @sample's, and run-,build-
and lib-depends.
- Tweak some CATEGORIES
The new infrastructure makes it very easy for us to port the missing KDE5
applications.
Feedback from kn@ Thanks!
   2018-12-13 12:07:25 by Rafael Sadowski | Files touched by this commit (1)
Log message:
Unbreak khelpcenter
kinit is not only a run dependency, it's also a build dependency.
Spotted by naddy@ and ajacoutot@ Thanks!
   2018-12-13 09:01:56 by Antoine Jacoutot | Files touched by this commit (1)
Log message:
Mark BROKEN.
CMake Error at /usr/local/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:137 (message):
Could NOT find KF5 (missing: Init) (found suitable version "5.51.0",
minimum required is "5.20.0")
Call Stack (most recent call first):
/usr/local/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:378 (_FPHSA_FAILURE_MESSAGE)
/usr/local/share/ECM/find-modules/FindKF5.cmake:110 (find_package_handle_standard_args)
CMakeLists.txt:27 (find_package)